Skocz do zawartości
  • 0

Dziwny problem ze skryptem na gui /crafringi


DeepesT

Pytanie

Witam napisałem sobie skrypt na /craftingi ale on jakos nie działa i nie wiem czemu ktos pomoże o to kod,problem polega na tym i po wgraniu skryptu to wyskakuje error: player inventory is not an item stack lub też iż because the latter is neither an item type nor an item stack. Dziękuję za Pomoc

Skript na wersje 1.8.8 (Najnowszy czyli 2.5.3)

 

Edytowane przez xNightix_
Nieaktywny

Naprawiam formatowanie na ciemnym motywie.

Odnośnik do komentarza
Udostępnij na innych stronach

19 odpowiedzi na to pytanie

Rekomendowane odpowiedzi

  • 0
4 minuty temu, DeepesT napisał:

Witam napisałem sobie skrypt na /craftingi ale on jakos nie działa i nie wiem czemu ktos pomoże o to kod,problem polega na tym i po wgraniu skryptu to wyskakuje error: player inventory is not an item stack lub też iż because the latter is neither an item type nor an item stack. Dziękuję za Pomoc

Skript na wersje 1.8.8 (Najnowszy czyli 2.5.3)

Najnowszy 2.5.3 na 1.8.8? To nie zadziała.

Edytowane przez xNightix_
Nieaktywny

Naprawiam cytat.

Odnośnik do komentarza
Udostępnij na innych stronach

  • 0
2 minuty temu, Kormic napisał:

Najnowszy 2.5.3 na 1.8.8? To nie zadziała.

a czemu wcześniej jakoś działało 

 

2 minuty temu, Kormic napisał:

Najnowszy 2.5.3 na 1.8.8? To nie zadziała.

o stąd pobierałem https://github.com/Matocolotoe/Skript-1.8/releases

Glicz

Łączę posty.

Notatka dodana przez Glicz

Odnośnik do komentarza
Udostępnij na innych stronach

  • 0
1 minutę temu, DeepesT napisał:

a czemu wcześniej jakoś działało 

Dobra, w takim razie włącz serwer bez dodatków do Skripta i zobacz czy zadziała. Zamień również 'open chest' na 'open chest inventory'.

Edytowane przez Kormic
Odnośnik do komentarza
Udostępnij na innych stronach

  • 0

No więc,

  1. Możesz zmienić te 'open chest with 3 rows...' z SkQuery na 'open chest inventory with 3 rows...' z czystego skripta.
  2. 5 minut temu, DeepesT napisał:

     player inventory is not an item stack lub też iż because the latter is neither an item type nor an item stack.

    Powiedz która linijka wywali Ci ten błąd 
Odnośnik do komentarza
Udostępnij na innych stronach

  • 0
Teraz, DeepesT napisał:

jasne: o to kod skripta: 

 

Aby ustawić slot na kilka przedmiotów musisz zrobić:
'set slot of player's current inventory to %ilość% of %przedmiot%'

Pozamieniaj wszystkie 'open chest with...' na 'open chest inventory with...' ze skripta

Odnośnik do komentarza
Udostępnij na innych stronach

  • 0
9 minut temu, Glitchtrap napisał:

a może pokażesz mi ten kod i błędy w postaci forumowego code?

a nie wiem jak mam pokazać te błędy w postaci forumowego code ?

 

4 minuty temu, Glitchtrap napisał:

Aby ustawić slot na kilka przedmiotów musisz zrobić:
'set slot of player's current inventory to %ilość% of %przedmiot%'

Pozamieniaj wszystkie 'open chest with...' na 'open chest inventory with...' ze skripta

Panie szefie nadal nie działa ale szczerze to jest dziwne wcześniej działało a teraz takie cos :( 

Glicz

Łączę posty.

Notatka dodana przez Glicz

Odnośnik do komentarza
Udostępnij na innych stronach

  • 0
4 minuty temu, DeepesT napisał:

a nie wiem jak mam pokazać te błędy w postaci forumowego code ?

 

Panie szefie nadal nie działa ale szczerze to jest dziwne wcześniej działało a teraz takie cos :( 

Spróbuj może odpalić samego skripta bez żadnych dodatków (o ile jakieś masz)
W konsoli przeładuj skrypt, skopiuj błędy i wstaw w code, będzie mi łatwiej stwierdzić co nie działa.

Odnośnik do komentarza
Udostępnij na innych stronach

  • 0
3 minuty temu, Glitchtrap napisał:

Ohoho, dużo tego :/, Czy miałeś wcześniej jakieś dodatki, których wymagały skrypty? Jeżeli tak, to teraz je wgraj i podaj błędy.

tylko ja to robię na localhost więc na pewno błędy będą bo to taki komputer a i wiesz wersja plików dodatkowych do skripta też się mg gryźć i mogą być błędy 

 

3 minuty temu, Glitchtrap napisał:

Ohoho, dużo tego :/, Czy miałeś wcześniej jakieś dodatki, których wymagały skrypty? Jeżeli tak, to teraz je wgraj i podaj błędy.

ale niech pan zobaczy miałem serwer na titakaxe z identycznymi plikami i wszystko działało jakie to dziwne 

Glicz

Łączę posty.

Notatka dodana przez Glicz

Odnośnik do komentarza
Udostępnij na innych stronach

  • 0
1 minutę temu, DeepesT napisał:

tylko ja to robię na localhost więc na pewno błędy będą bo to taki komputer a i wiesz wersja plików dodatkowych do skripta też się mg gryźć i mogą być błędy 

 

ale niech pan zobaczy miałem serwer na titakaxe z identycznymi plikami i wszystko działało jakie to dziwne 

Prawdopodobnie mogło się coś zepsuć na localhoscie, spróbuj zrobić nowego (jeżeli potrzebujesz).

Jeżeli działa, to mam rozumieć, że do zamknięcia?

Odnośnik do komentarza
Udostępnij na innych stronach

  • 0
Teraz, DeepesT napisał:

tylko ja to robię na localhost więc na pewno błędy będą bo to taki komputer a i wiesz wersja plików dodatkowych do skripta też się mg gryźć i mogą być błędy 

Spójrz jaki jest błąd na górze logów. Jeżeli możesz, zaktualizuj system do wersji 64-bitowej, a następnie zainstaluj Javę w wersji 64-bitowej, aby uniknąć zbędnych wiadomości w konsoli.

Spróbuj rzeczy, które wymienię poniżej:

  • wyłącz serwer, zapisz sobie gdzieś skrypty i/lub zmienne, usuń folder Skript, włącz ponownie serwer, wrzuć z powrotem swoje wcześniej zapisane skrypty i/lub zmienne do nowo utworzonego folderu Skript
  • pobierz ponownie Skripta
  • zaktualizuj silnik serwera
Odnośnik do komentarza
Udostępnij na innych stronach

  • 0
1 minutę temu, Glitchtrap napisał:

Prawdopodobnie mogło się coś zepsuć na localhoscie, spróbuj zrobić nowego (jeżeli potrzebujesz).

Jeżeli działa, to mam rozumieć, że do zamknięcia?

tylko jak wgrywam to np na aternos to identyczne blędy .... ja już zgłupiałem miałem te pliki na 3 edycjach i wszystko działało zamknąłem serwer i przekopiowałem sobie pliki a teraz nie działają no pacz pan no ufo.

serwer stał na titanaxe

Odnośnik do komentarza
Udostępnij na innych stronach

  • 0
1 minutę temu, DeepesT napisał:

tylko jak wgrywam to np na aternos to identyczne blędy .... ja już zgłupiałem miałem te pliki na 3 edycjach i wszystko działało zamknąłem serwer i przekopiowałem sobie pliki a teraz nie działają no pacz pan no ufo.

serwer stał na titanaxe

spróbuj wygenerować wszystkie pliki od nowa (zrobić nowego localhosta) i wgrać wszystko co potrzeba (bez starych folderów, pobierz od nowa z internetu)

Odnośnik do komentarza
Udostępnij na innych stronach

  • 0
2 minuty temu, DeepesT napisał:

tylko jak wgrywam to np na aternos to identyczne blędy .... ja już zgłupiałem miałem te pliki na 3 edycjach i wszystko działało zamknąłem serwer i przekopiowałem sobie pliki a teraz nie działają no pacz pan no ufo.

serwer stał na titanaxe

Aternos ma wsparcie do Skripta 2.1.2, więc ciężko przewidzieć jak to się będzie zachowywało.

Titanaxe chociaż jest gównianym hostingiem, przynajmniej pozwala ci wgrać swoje pliki.

Pewnie na Titanaxe nie było błędów z powodu różnicy w systemach.

Odnośnik do komentarza
Udostępnij na innych stronach

  • 0
1 minutę temu, Kormic napisał:

Aternos ma wsparcie do Skripta 2.1.2, więc ciężko przewidzieć jak to się będzie zachowywało.

Titanaxe chociaż jest gównianym hostingiem, przynajmniej pozwala ci wgrać swoje pliki.

Pewnie na Titanaxe nie było błędów z powodu różnicy w systemach.

pewnie tak wie pan czy titanaxe jest gówniany to kwestia gustu ja mg powiedziec iż bez żadnych problemów utrzymał mi 60 graczy

Odnośnik do komentarza
Udostępnij na innych stronach

Dołącz do dyskusji

Możesz dodać zawartość już teraz a zarejestrować się później. Jeśli posiadasz już konto, zaloguj się aby dodać zawartość za jego pomocą.

Nieaktywny
Odpowiedz na pytanie...

×   Wklejono zawartość z formatowaniem.   Usuń formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Odnośnik został automatycznie osadzony.   Przywróć wyświetlanie jako odnośnik

×   Przywrócono poprzednią zawartość.   Wyczyść edytor

×   Nie możesz bezpośrednio wkleić grafiki. Dodaj lub załącz grafiki z adresu URL.

  • Ostatnio przeglądający   0 użytkowników

    • Brak zarejestrowanych użytkowników przeglądających tę stronę.
×
×
  • Dodaj nową pozycję...