Skocz do zawartości
  • 0
jndooo

Skrypt na zmiane spawnerkow

Pytanie

Użytkownik

Szukam skryptu na zmianę spawnerków pod komenda /spawner  i dodatkowo gracz musi patrzec na spawner i z lista w gui dodatkowo zmiana spawnera ma kosztowac np. 1000$ wystarczy mi pokazać schemat jak zrobić a ja sb zrobie zmiane na różne moby już tyle i chciał bym kazdy mob miał uprawnienie np. zombie.spawner

Edytowane przez jndooo

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

10 odpowiedzi na to pytanie

Rekomendowane odpowiedzi

Użytkownik
  • 0

dzień dobry. ja myślę że to jest niemożliwe w pluginie Skript bo jak wpisujesz (set location of block to {_block}) to skript wpisuje to jako X: 129.21, Y: 217, Z: 218. i tak to niemoże być bo jak się wpisuje /setblock X: 121 Y: 213 Z:21 mob_spawner itd. to tak nie może być bo jak się wpisuje komendę setblock muszą być same cyfry a nie może być żadnej litery i minecraft tego blocku nie wstawia. może jest jakieś rozwiązanie ale nieznam :(

 

Edit:

command /spawner [<text>]:
    trigger:
        if arg 1 is "zombie":
            if player has permission "spawner.zombie":
                set {_block} to player's target block
                set {_loc.block} to location of target block
                if {_block} is "mob_spawner":
                    send "&2Zmieniono spawner na 'zombie'" to player
                    execute console command "/setblock %{_loc.block}% minecraft:spawner{SpawnData:{id:zombie}}"

Edytowane przez filip2101

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
VIP++
  • 0

@Helios1993 o tym to ja wiem, że bez essentials i valut to nie zadziała. Ja napisałem jaki jest potrzebny addon do skripta.

To może mam jeszcze wszystkie pluginy wypisywać, żeby to działało?

Edytowane przez kijl

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Użytkownik
  • 0
53 minuty temu, Helios1993 napisał:

@jndoooto po co ci ten skrypt

 

by gracz mógł zmienic spawner w jakiś przejrzysty sposób

10 godzin temu, kijl napisał:

Dodatek jaki jest wymagany to TuSke

Sprawdzane i 0 błędów

@jndooo

Czy TuSke  wpierany jest na 1.12.2?

HeezQ

Łączę posty

Notatka dodana przez HeezQ

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Dołącz do dyskusji

Możesz dodać zawartość i zarejestrować się później. Jeżeli masz już konto, zaloguj się, aby dodać zawartość za jego pomocą.

Losowy awatar
Odpowiedz na pytanie...

×   Wklejono zawartość z formatowaniem.   Usuń formatowanie

  Maksymalnie dozwolone są tylko 75 emotikony.

×   Odnośnik został automatycznie osadzony.   Przywróć wyświetlanie jako odnośnik

×   Przywrócono poprzednią zawartość.   Wyczyść edytor

×   Nie możesz bezpośrednio wkleić grafiki. Dodaj lub załącz grafiki z adresu URL.


  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×