Skocz do zawartości
  • 0

Problem z uzupełnianiem komendy tabulatorem


crosby
 Udostępnij

Pytanie

Siemka,
Dłubiąc dzisiaj przy skripcie natrafiłem na problem który nie pozwala mi zasnąć, polega on na tym że Tab Completer działa super w przypadku stworzenia komendy w ten sposób:
 

command /test [<text>]:
	{kod}

ale nie chce działać w takim przypadku:
 

command /cUtils:test [<text>]:
	{kod}

Skript ładuje się bez błędów lecz po zmianie w completerze z wersji pierwszej(tej co działa) na drugą nagle wszystko idzie w łeb i nie działają podpowiedzi pod tabulatorem.
Próbowałem robić to na parę sposobów, lecz bez skutku. Przerabiał ktoś może taki błąd i wie jak to naprawić?
(zależy mi na tym by utrzymać wszystkie komendy z tym "prefixem" by fajnie się sortowały w grze)

Thanks from mountain wszystkim co spróbują znaleźć rozwiązanie, w razie czego podsyłam fragment tab completera byście wiedzieli jak to wygląda bez szukania w necie
 

on tab completer for "/cUtils:sb":
    set {_completer::*} to "on" and "off"
    loop {_completer::*}:
        add loop-value to completions

 

Edytowane przez crosby
Poprawa złożoności zdań
Odnośnik do komentarza
Udostępnij na innych stronach

1 odpowiedź na to pytanie

Rekomendowane odpowiedzi

Dołącz do dyskusji

Możesz dodać zawartość już teraz a zarejestrować się później. Jeśli posiadasz już konto, zaloguj się aby dodać zawartość za jego pomocą.

Nieaktywny
Odpowiedz na pytanie...

×   Wklejono zawartość z formatowaniem.   Usuń formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Odnośnik został automatycznie osadzony.   Przywróć wyświetlanie jako odnośnik

×   Przywrócono poprzednią zawartość.   Wyczyść edytor

×   Nie możesz bezpośrednio wkleić grafiki. Dodaj lub załącz grafiki z adresu URL.

 Udostępnij

  • Ostatnio przeglądający   0 użytkowników

    • Brak zarejestrowanych użytkowników przeglądających tę stronę.
×
×
  • Dodaj nową pozycję...