Skocz do zawartości
  • 0

An internal error (...)


ICD10
 Udostępnij

Pytanie

Witam,

stworzyłem na swoim testowym VPS-ie skrypt, tak dla przypomnienia jak to w ogóle działało. Podczas próby uruchomienia komendy, która do niego należy wyświetlił mi się błąd, konsola niewiele mi mówi. Mam tylko dwa pluginy (World Edit i Skript), całość stoi na silniku Spigot 1.9, również na takiej wersji się znajdowałem. Podczas wczytywania skryptu nie wywala żadnych błędów.

crHaBVj.png

 

Również wersja Skript jest aktualna:

dLlHZAe.png

 

Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!

Konsola błędów daje jednak więcej:

[15:59:18 INFO]: XXX: /czat zablokuj
[15:59:18 ERROR]: Could not pass event PlayerCommandPreprocessEvent to Skript v2.1.2
org.bukkit.event.EventException
	at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:310) ~[spigot-1.9.jar:git-Spigot-f32adba-bf43ca6]
	at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62) ~[spigot-1.9.jar:git-Spigot-f32adba-bf43ca6]
	at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:502) [spigot-1.9.jar:git-Spigot-f32adba-bf43ca6]
	at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:487) [spigot-1.9.jar:git-Spigot-f32adba-bf43ca6]
	at net.minecraft.server.v1_9_R1.PlayerConnection.handleCommand(PlayerConnection.java:1334) [spigot-1.9.jar:git-Spigot-f32adba-bf43ca6]
	at net.minecraft.server.v1_9_R1.PlayerConnection.a(PlayerConnection.java:1177) [spigot-1.9.jar:git-Spigot-f32adba-bf43ca6]
	at net.minecraft.server.v1_9_R1.PacketPlayInChat.a(PacketPlayInChat.java:45) [spigot-1.9.jar:git-Spigot-f32adba-bf43ca6]
	at net.minecraft.server.v1_9_R1.PacketPlayInChat.a(PacketPlayInChat.java:1) [spigot-1.9.jar:git-Spigot-f32adba-bf43ca6]
	at net.minecraft.server.v1_9_R1.PlayerConnectionUtils$1.run(SourceFile:13) [spigot-1.9.jar:git-Spigot-f32adba-bf43ca6]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471) [?:1.7.0_80]
	at java.util.concurrent.FutureTask.run(FutureTask.java:262) [?:1.7.0_80]
	at net.minecraft.server.v1_9_R1.SystemUtils.a(SourceFile:45) [spigot-1.9.jar:git-Spigot-f32adba-bf43ca6]
	at net.minecraft.server.v1_9_R1.MinecraftServer.D(MinecraftServer.java:721) [spigot-1.9.jar:git-Spigot-f32adba-bf43ca6]
	at net.minecraft.server.v1_9_R1.DedicatedServer.D(DedicatedServer.java:400) [spigot-1.9.jar:git-Spigot-f32adba-bf43ca6]
	at net.minecraft.server.v1_9_R1.MinecraftServer.C(MinecraftServer.java:660) [spigot-1.9.jar:git-Spigot-f32adba-bf43ca6]
	at net.minecraft.server.v1_9_R1.MinecraftServer.run(MinecraftServer.java:559) [spigot-1.9.jar:git-Spigot-f32adba-bf43ca6]
	at java.lang.Thread.run(Thread.java:745) [?:1.7.0_80]
Caused by: java.lang.NoSuchMethodError: org.bukkit.Bukkit.getOnlinePlayers()[Lorg/bukkit/entity/Player;
	at ch.njol.skript.effects.EffBroadcast.execute(EffBroadcast.java:72) ~[?:?]
	at ch.njol.skript.lang.Effect.run(Effect.java:50) ~[?:?]
	at ch.njol.skript.lang.TriggerItem.walk(TriggerItem.java:63) ~[?:?]
	at ch.njol.skript.lang.TriggerItem.walk(TriggerItem.java:91) ~[?:?]
	at ch.njol.skript.lang.Trigger.execute(Trigger.java:53) ~[?:?]
	at ch.njol.skript.command.ScriptCommand$1.call(ScriptCommand.java:220) ~[?:?]
	at ch.njol.skript.command.ScriptCommand$1.call(ScriptCommand.java:1) ~[?:?]
	at ch.njol.skript.util.Task.callSync(Task.java:139) ~[?:?]
	at ch.njol.skript.command.ScriptCommand.execute(ScriptCommand.java:193) ~[?:?]
	at ch.njol.skript.command.Commands.handleCommand(Commands.java:260) ~[?:?]
	at ch.njol.skript.command.Commands$1.onPlayerCommand(Commands.java:155) ~[?:?]
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.7.0_80]
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) ~[?:1.7.0_80]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.7.0_80]
	at java.lang.reflect.Method.invoke(Method.java:606) ~[?:1.7.0_80]
	at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:306) ~[spigot-1.9.jar:git-Spigot-f32adba-bf43ca6]
	... 16 more
[15:59:18 ERROR]: null
org.bukkit.command.CommandException: Unhandled exception executing command 'czat' in plugin Skript v2.1.2
	at org.bukkit.command.PluginCommand.execute(PluginCommand.java:46) ~[spigot-1.9.jar:git-Spigot-f32adba-bf43ca6]
	at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:141) ~[spigot-1.9.jar:git-Spigot-f32adba-bf43ca6]
	at org.bukkit.craftbukkit.v1_9_R1.CraftServer.dispatchCommand(CraftServer.java:645) ~[spigot-1.9.jar:git-Spigot-f32adba-bf43ca6]
	at net.minecraft.server.v1_9_R1.PlayerConnection.handleCommand(PlayerConnection.java:1342) [spigot-1.9.jar:git-Spigot-f32adba-bf43ca6]
	at net.minecraft.server.v1_9_R1.PlayerConnection.a(PlayerConnection.java:1177) [spigot-1.9.jar:git-Spigot-f32adba-bf43ca6]
	at net.minecraft.server.v1_9_R1.PacketPlayInChat.a(PacketPlayInChat.java:45) [spigot-1.9.jar:git-Spigot-f32adba-bf43ca6]
	at net.minecraft.server.v1_9_R1.PacketPlayInChat.a(PacketPlayInChat.java:1) [spigot-1.9.jar:git-Spigot-f32adba-bf43ca6]
	at net.minecraft.server.v1_9_R1.PlayerConnectionUtils$1.run(SourceFile:13) [spigot-1.9.jar:git-Spigot-f32adba-bf43ca6]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471) [?:1.7.0_80]
	at java.util.concurrent.FutureTask.run(FutureTask.java:262) [?:1.7.0_80]
	at net.minecraft.server.v1_9_R1.SystemUtils.a(SourceFile:45) [spigot-1.9.jar:git-Spigot-f32adba-bf43ca6]
	at net.minecraft.server.v1_9_R1.MinecraftServer.D(MinecraftServer.java:721) [spigot-1.9.jar:git-Spigot-f32adba-bf43ca6]
	at net.minecraft.server.v1_9_R1.DedicatedServer.D(DedicatedServer.java:400) [spigot-1.9.jar:git-Spigot-f32adba-bf43ca6]
	at net.minecraft.server.v1_9_R1.MinecraftServer.C(MinecraftServer.java:660) [spigot-1.9.jar:git-Spigot-f32adba-bf43ca6]
	at net.minecraft.server.v1_9_R1.MinecraftServer.run(MinecraftServer.java:559) [spigot-1.9.jar:git-Spigot-f32adba-bf43ca6]
	at java.lang.Thread.run(Thread.java:745) [?:1.7.0_80]
Caused by: java.lang.NoSuchMethodError: org.bukkit.Bukkit.getOnlinePlayers()[Lorg/bukkit/entity/Player;
	at ch.njol.skript.effects.EffBroadcast.execute(EffBroadcast.java:72) ~[?:?]
	at ch.njol.skript.lang.Effect.run(Effect.java:50) ~[?:?]
	at ch.njol.skript.lang.TriggerItem.walk(TriggerItem.java:63) ~[?:?]
	at ch.njol.skript.lang.TriggerItem.walk(TriggerItem.java:91) ~[?:?]
	at ch.njol.skript.lang.Trigger.execute(Trigger.java:53) ~[?:?]
	at ch.njol.skript.command.ScriptCommand$1.call(ScriptCommand.java:220) ~[?:?]
	at ch.njol.skript.command.ScriptCommand$1.call(ScriptCommand.java:1) ~[?:?]
	at ch.njol.skript.util.Task.callSync(Task.java:139) ~[?:?]
	at ch.njol.skript.command.ScriptCommand.execute(ScriptCommand.java:193) ~[?:?]
	at ch.njol.skript.command.ScriptCommand.onCommand(ScriptCommand.java:170) ~[?:?]
	at org.bukkit.command.PluginCommand.execute(PluginCommand.java:44) ~[spigot-1.9.jar:git-Spigot-f32adba-bf43ca6]
	... 15 more
[15:59:35 WARN]: Exception in thread "Craft Scheduler Thread - 4" 
[15:59:35 WARN]: org.apache.commons.lang.UnhandledException: Plugin Skript v2.1.2 generated an exception while executing task 7
	at org.bukkit.craftbukkit.v1_9_R1.scheduler.CraftAsyncTask.run(CraftAsyncTask.java:56)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.NoSuchMethodError: org.bukkit.Server.getOnlinePlayers()[Lorg/bukkit/entity/Player;
	at ch.njol.skript.Metrics.postPlugin(Metrics.java:347)
	at ch.njol.skript.Metrics$1.run(Metrics.java:235)
	at org.bukkit.craftbukkit.v1_9_R1.scheduler.CraftTask.run(CraftTask.java:71)
	at org.bukkit.craftbukkit.v1_9_R1.scheduler.CraftAsyncTask.run(CraftAsyncTask.java:53)
	... 3 more

Odnośnik do komentarza
Udostępnij na innych stronach

6 odpowiedzi na to pytanie

Rekomendowane odpowiedzi

  • 0

Masz tutaj działające. A jak nie chce sie tb pobierać to zdecyduj sie czy spacje czy taby stosujesz xD.
Zastosowałem spacje i działa.

qh5kqMjj.sk
A jak to nie to. Co też tak sądzę bo po kodzie błędu wersji odpowiedniej pluginu skript bądź rozszerzenia do niego nie masz.
 

Edytowane przez -+RoNiN+-
Odnośnik do komentarza
Udostępnij na innych stronach

  • 0

U mnie normalnie działa. To co masz na górze w tym swoim errorze jest związane z pluginem skript or rozszerzeniem do niego.
 

Cały error pokazuje tb że to związane z pluginem. Krótko mówiąc zła wersja.
Ta wersja działa na 100% na 1.10 może zadziała na 1.9 na twoim:

 Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!

va.lang.NoSuchMethodError: org.bukkit.Bukkit.getOnlinePlayers()[Lorg/bukkit/entity/Player;
	at ch.njol.skript.effects.EffBroadcast.execute(EffBroadcast.java:72) ~[?:?]
Edytowane przez -+RoNiN+-
Odnośnik do komentarza
Udostępnij na innych stronach

Nieaktywny
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.
 Udostępnij

  • Ostatnio przeglądający   0 użytkowników

    • Brak zarejestrowanych użytkowników przeglądających tę stronę.
×
×
  • Dodaj nową pozycję...