Skocz do zawartości
  • 0

Włączanie


maxcom1
 Udostępnij

Pytanie

Hej. Używam papera 1.12.2 i Skript 2.4.1.

Niestety skript i jego addony nie chcą się włączyć, i nie wiem dlaczego.

Błędy z konsoli:

[12:18:48 ERROR]: Error occurred while enabling Skript v2.4.1 (Is it up to date?)
java.lang.ExceptionInInitializerError: null
        at ch.njol.skript.aliases.Aliases.<clinit>(Aliases.java:142) ~[?:?]
        at ch.njol.skript.Skript.onEnable(Skript.java:402) ~[?:?]
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:264) ~[Paper-1.12.2-b1618.jar:git-Paper-1618]
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:316) ~[Paper-1.12.2-b1618.jar:git-Paper-1618]
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) ~[Paper-1.12.2-b1618.jar:git-Paper-1618]
        at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugin(CraftServer.java:395) ~[Paper-1.12.2-b1618.jar:git-Paper-1618]
        at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugins(CraftServer.java:344) ~[Paper-1.12.2-b1618.jar:git-Paper-1618]
        at net.minecraft.server.v1_12_R1.MinecraftServer.t(MinecraftServer.java:442) ~[Paper-1.12.2-b1618.jar:git-Paper-1618]
        at net.minecraft.server.v1_12_R1.MinecraftServer.l(MinecraftServer.java:403) ~[Paper-1.12.2-b1618.jar:git-Paper-1618]
        at net.minecraft.server.v1_12_R1.MinecraftServer.a(MinecraftServer.java:341) ~[Paper-1.12.2-b1618.jar:git-Paper-1618]
        at net.minecraft.server.v1_12_R1.DedicatedServer.init(DedicatedServer.java:289) ~[Paper-1.12.2-b1618.jar:git-Paper-1618]
        at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:616) ~[Paper-1.12.2-b1618.jar:git-Paper-1618]
        at java.lang.Thread.run(Unknown Source) [?:1.8.0_181]
Caused by: java.lang.IllegalArgumentException: No enum constant org.bukkit.Material.ACACIA_BOAT
        at java.lang.Enum.valueOf(Unknown Source) ~[?:1.8.0_181]
        at org.bukkit.Material.valueOf(Material.java:71) ~[Paper-1.12.2-b1618.jar:git-Paper-1618]
        at ch.njol.skript.aliases.MaterialRegistry.load(MaterialRegistry.java:61) ~[?:?]
        at ch.njol.skript.aliases.ItemData.<clinit>(ItemData.java:108) ~[?:?]
        ... 13 more

Proszę o pomoc!

Odnośnik do komentarza
Udostępnij na innych stronach

10 odpowiedzi na to pytanie

Rekomendowane odpowiedzi

  • 0

Zawsze gdy instalujesz plugin to nie patrzysz na jaką on jest wersję? No kurna przecież każda z nich jest opisana i wystarczy się tylko wczytać :/

To tak jak zamawianie ubrań przez internet bez patrzenia na rozmiar i skład 

>może będą pasować
>pobiorę pierwszy lepszy, może zadziała

 

Edytowane przez PanMaruda
Odnośnik do komentarza
Udostępnij na innych stronach

  • 0

Widzę że nie dociera to co napisałem...

Znajdź plugin na swoją wersję, żadne 2.4 ani 2.5 NIE WSPIERA 1.12 co w dosłownym tłumaczeniu oznacza że masz szukać i próbować starsze wersje (ALE NOWSZE NIŻ 2.2, bo tamte również NIE WSPIERAJĄ 1.12)

 

Odnośnik do komentarza
Udostępnij na innych stronach

Dołącz do dyskusji

Możesz dodać zawartość już teraz a zarejestrować się później. Jeśli posiadasz już konto, zaloguj się aby dodać zawartość za jego pomocą.

Nieaktywny
Odpowiedz na pytanie...

×   Wklejono zawartość z formatowaniem.   Usuń formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Odnośnik został automatycznie osadzony.   Przywróć wyświetlanie jako odnośnik

×   Przywrócono poprzednią zawartość.   Wyczyść edytor

×   Nie możesz bezpośrednio wkleić grafiki. Dodaj lub załącz grafiki z adresu URL.

 Udostępnij

  • Ostatnio przeglądający   0 użytkowników

    • Brak zarejestrowanych użytkowników przeglądających tę stronę.
×
×
  • Dodaj nową pozycję...