Skocz do zawartości
  • 0

Serwer zwariował - problem z skriptem i clearlag


Nieaktywny

Pytanie

Logi:

Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!

Skript wywala bez sensowne błędy co włączenie serwera każde a clearlag plugin jest dobrze zainstalowany jak na każdym moim serwerze i od paru dni wywala taki błąd i się nie ładuje na serwer - nie działa plugin wcale nawet w pl go nie ma. Ktoś wie dlaczego

Wersja serwera 1.7.2, silnik Spigot

Pluginy są na wersje na 1.7.2 jak na każdym moim serwerze (nawet skopiowałem plugin z innego serwera mojego mimo to ten błąd jest) skript pobrałem i wgrałem jeszcze raz nadal nic.

Ktoś wie o co chodzi z tym ? Serwer zwariował (ode mnie <3 ) ?

Edytowane przez Nieaktywny
Odnośnik do komentarza
Udostępnij na innych stronach

9 odpowiedzi na to pytanie

Rekomendowane odpowiedzi

  • 0
16 minut temu, Libter napisał:

Plik ClearLagg.jar jest uszkodzony, pobierz go jeszcze raz z Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!.

Plugin działa za każdym razem jak go gram ponownie ale po restarcie już się nie ładuje. Wgrałem z tej strony i to samo jest.

Skript też wariuje. Na innych serwerach działa jednak poprawnie tylko tu od paru dni te błędy są. :/

Odnośnik do komentarza
Udostępnij na innych stronach

  • 0
2 godziny temu, ProgrammingWizzard napisał:

oraz podaj zawartość plugin.yml z pluginu ClearLag.

To nie plik plugin.yml jest problematyczny, cały JAR jest zepsuty:

Caused by: java.util.zip.ZipException: error in opening zip file
        at java.util.zip.ZipFile.open(Native Method) ~[?:1.7.0_80]
        at java.util.zip.ZipFile.<init>(ZipFile.java:215) ~[?:1.7.0_80]
        at java.util.zip.ZipFile.<init>(ZipFile.java:145) ~[?:1.7.0_80]
        at java.util.jar.JarFile.<init>(JarFile.java:154) ~[?:1.7.0_80]
        at java.util.jar.JarFile.<init>(JarFile.java:118) ~[?:1.7.0_80]
        at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:172) ~[mc.jar:git-Spigot-1.7.2-R0.3-122-gb58e277]
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:74) ~[mc.jar:git-Spigot-1.7.2-R0.3-122-gb58e277]
        ... 6 more

 

Odnośnik do komentarza
Udostępnij na innych stronach

  • 0

Problemy zaczęły się gdy zaktualizowałem parę dni temu serwer do 1.7-1.8 ale potem znowu przełączyłem na 1.7.2 i odkąd zmieniłem na 1.7-1.8 to ciągle na każdej wersji te same błędy jakby pliki serwera globalne coś oszalały. i jeszcze jeden problem zrobiłem ranking według tuta pirata ale w logach wyskakuje ciągle ten błąd:

[Skript] Possible name conflict of variables {lista::*} and {lista::%loop-index%} (there might be more conflicts). (Standard.sk, line 273: set {_num} to size of {_lista::*}')

Pluginy są dobrze to coś z plikami serwera jest bo za pierwszym razem (jak się pobawie plikami i je zaktualizuje itp) to działa normalnie po restarcie skript i clearlag przestają działać poprawnie. Do hostingu będę mamrotać najwyżej cały miesiąc <3. Przynajmniej ten błąd z rankingiem rozwiązać. Eee cały kod może dam:

command /TopPvP [<integer=1>]:
    trigger:
        set {_strony} to rounded up (size of {killee::*} / 5)
        arg is between 1 and {_strony}:
            send "&c&l&m[-----]&r  &a&lRanking PvP  &c&l&m[-----]"
            loop {killee::*}:
                set {_lista::%loop-index%} to loop-value
            set {_num} to size of {_lista::*}
            set {_max} to arg * 5
            set {_min} to {_max} - 4
            loop {_max} times:
                loop {_lista::*}:
                    {_wartosc.%loop-number%} is not set:
                        set {_wartosc.%loop-number%} to loop-value
                        set {_nazwa.%loop-number%} to loop-index
                    loop-value is more than {_wartosc.%loop-number%}:
                        set {_wartosc.%loop-number%} to loop-value
                        set {_nazwa.%loop-number%} to loop-index
                delete {_lista::%{_nazwa.%loop-number%}%}
            loop {_max} times:
                loop-number is between {_min} and {_max}
                loop-number <= {_num}:
                    send "&6%loop-number%. &9%{nick::%{_nazwa.%loop-number%}%}% &c(%{_wartosc.%loop-number%}%)"
                {_max} is more than {_num}:
                    set {_r} to {_num}
            loop {_max} - {_num} times:
                add 1 to {_r}
                send "%{_r}%. brak"
            send "Strona: %arg% z %{_strony}%"
            stop
        {_strony} is 1:
            send "Wyniki mieszcza sie na 1 stronie."
            stop
        send "Wyniki mieszcza sie na %{_strony}% stronach."

Edytowane przez Nieaktywny
Odnośnik do komentarza
Udostępnij na innych stronach

  • 0

Dobra jednak może i nie winna tamtych plików. Pokombinuje coś z pluginami tymi najwyżej. Ale skript to nie wiem jak naprawić :/ skoro nawet wgranie nic nie dało i wywala błędy na wszystko raz jak dałem by naprawiało itemy po uderzeniu każdemu atakującemu to naprawiało potworą też i przez to serwer jak mob uderzył kogoś to wywalało cały serwer. Skript ma wiele tajemnic. Clearlag pisało invalid .yml to pobawię się z configiem najwyżej.

#EDIT - ClearLag po restarcie bez zmiany yml itp i tak przestaje działać :/ Może winna procesora ? mam serv na hoście i przy starcie serwera mam około 98% użytku procesora <3 xd
#2 EDIT Te same błędy pojawiły się na kolejnym serwerze :/
#3 EDIT Wgrałem starszą wersje clearlag to samo z skriptem może zrobie
Edytowane przez Nieaktywny
Odnośnik do komentarza
Udostępnij na innych stronach

  • 0

NOMAD polecam napisać do BOK ;) też tak miałem jednak napisałem i po upływie 1-2 h było dobrze (jeśli to jest ten sam błąd co ja miałem polecam usunąć cały skript i pobrać jeszcze raz ) pamiętaj skopiuj  wszystkie skrypty , no chyba że je masz to nie musisz ;) (co do clearlagg to nie wiem :/ )

Odnośnik do komentarza
Udostępnij na innych stronach

Nieaktywny
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.
  • Ostatnio przeglądający   0 użytkowników

    • Brak zarejestrowanych użytkowników przeglądających tę stronę.
×
×
  • Dodaj nową pozycję...