Skocz do zawartości

Pytanie

Użytkownik

Witam.Mam problem ze skryptami.Otóż postawiłem serwer na craftserve i byłem z tego hostingu zadowolony, do czasu aż nie zacząłem się bawić w skrypty.Okazało się, że jedynym skryptem który działa jest ten na czyszczenie czatu.

Próbowałem zainstalować sdDrop ale przy wpisywaniu /skript reload all

Pojawia się error i nie chce działać.Serwer jest na wersji 1.8

W konsoli pokazuje się taki błąd

21:21:48 ERROR]: #!#!
[21:21:48 ERROR]: #!#! [Skript] Severe Error:
[21:21:48 ERROR]: #!#! Could not load drop.sk
[21:21:48 ERROR]: #!#!
[21:21:48 ERROR]: #!#! If you're developing an add-on for Skript this likely means that you have done something wrong.
[21:21:48 ERROR]: #!#! If you're a server admin however please go to Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!
[21:21:48 ERROR]: #!#! and check whether this error has already been reported.
[21:21:48 ERROR]: #!#! If not please create a new ticket with a meaningful title, copy & paste this whole error into it,
[21:21:48 ERROR]: #!#! and describe what you did before it happened and/or what you think caused the error.
[21:21:48 ERROR]: #!#! If you think that it's a trigger that's causing the error please post the trigger as well.
[21:21:48 ERROR]: #!#! By following this guide fixing the error should be easy and done fast.
[21:21:48 ERROR]: #!#!
[21:21:48 ERROR]: #!#! Stack trace:
[21:21:48 ERROR]: #!#! ch.njol.skript.SkriptAPIException: The class 'enchantment' does not provide a default expression. Either allow null (with %-enchantment%) or make it mandatory [pattern: [the] (%enchantment% level|level of [[the] enchantent]] %enchantment%) o(f|n) %itemtypes%]
[21:21:48 ERROR]: #!#! at ch.njol.skript.lang.SkriptParser.parse(SkriptParser.java:220)
[21:21:48 ERROR]: #!#! at ch.njol.skript.lang.SkriptParser.parse(SkriptParser.java:164)
[21:21:48 ERROR]: #!#! at ch.njol.skript.lang.SkriptParser.parseSingleExpr(SkriptParser.java:509)
[21:21:48 ERROR]: #!#! at ch.njol.skript.lang.SkriptParser.parseExpression(SkriptParser.java:294)
[21:21:48 ERROR]: #!#! at ch.njol.skript.lang.SkriptParser.parse_i(SkriptParser.java:990)
[21:21:48 ERROR]: #!#! at ch.njol.skript.lang.SkriptParser.parse(SkriptParser.java:209)
[21:21:48 ERROR]: #!#! at ch.njol.skript.lang.SkriptParser.parse(SkriptParser.java:164)
[21:21:48 ERROR]: #!#! at ch.njol.skript.lang.SkriptParser.parseSingleExpr(SkriptParser.java:509)
[21:21:48 ERROR]: #!#! at ch.njol.skript.lang.SkriptParser.parseObjectExpression(SkriptParser.java:380)
[21:21:48 ERROR]: #!#! at ch.njol.skript.lang.SkriptParser.parseExpression(SkriptParser.java:286)
[21:21:48 ERROR]: #!#! at ch.njol.skript.lang.SkriptParser.parse_i(SkriptParser.java:990)
[21:21:48 ERROR]: #!#! at ch.njol.skript.lang.SkriptParser.parse_i(SkriptParser.java:981)
[21:21:48 ERROR]: #!#! at ch.njol.skript.lang.SkriptParser.parse(SkriptParser.java:209)
[21:21:48 ERROR]: #!#! at ch.njol.skript.lang.SkriptParser.parse(SkriptParser.java:164)
[21:21:48 ERROR]: #!#! at ch.njol.skript.lang.Statement.parse(Statement.java:42)
[21:21:48 ERROR]: #!#! at ch.njol.skript.ScriptLoader.loadItems(ScriptLoader.java:615)
[21:21:48 ERROR]: #!#! at ch.njol.skript.lang.TriggerSection.<init>(TriggerSection.java:55)
[21:21:48 ERROR]: #!#! at ch.njol.skript.lang.Conditional.<init>(Conditional.java:44)
[21:21:48 ERROR]: #!#! at ch.njol.skript.ScriptLoader.loadItems(ScriptLoader.java:701)
[21:21:48 ERROR]: #!#! at ch.njol.skript.lang.TriggerSection.<init>(TriggerSection.java:55)
[21:21:48 ERROR]: #!#! at ch.njol.skript.lang.Conditional.<init>(Conditional.java:44)
[21:21:48 ERROR]: #!#! at ch.njol.skript.ScriptLoader.loadItems(ScriptLoader.java:701)
[21:21:48 ERROR]: #!#! at ch.njol.skript.ScriptLoader.loadScript(ScriptLoader.java:489)
[21:21:48 ERROR]: #!#! at ch.njol.skript.ScriptLoader.loadScripts(ScriptLoader.java:239)
[21:21:48 ERROR]: #!#! at ch.njol.skript.ScriptLoader.loadScripts(ScriptLoader.java:193)
[21:21:48 ERROR]: #!#! at ch.njol.skript.Skript.reload(Skript.java:548)
[21:21:48 ERROR]: #!#! at ch.njol.skript.SkriptCommand.onCommand(SkriptCommand.java:130)
[21:21:48 ERROR]: #!#! at org.bukkit.command.PluginCommand.execute(PluginCommand.java:44)
[21:21:48 ERROR]: #!#! at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:140)
[21:21:48 ERROR]: #!#! at org.bukkit.craftbukkit.v1_8_R1.CraftServer.dispatchCommand(CraftServer.java:625)
[21:21:48 ERROR]: #!#! at net.minecraft.server.v1_8_R1.PlayerConnection.handleCommand(PlayerConnection.java:1058)
[21:21:48 ERROR]: #!#! at net.minecraft.server.v1_8_R1.PlayerConnection.a(PlayerConnection.java:919)
[21:21:48 ERROR]: #!#! at net.minecraft.server.v1_8_R1.PacketPlayInChat.a(SourceFile:37)
[21:21:48 ERROR]: #!#! at net.minecraft.server.v1_8_R1.PacketPlayInChat.a(SourceFile:9)
[21:21:48 ERROR]: #!#! at net.minecraft.server.v1_8_R1.PacketHandleTask.run(SourceFile:13)
[21:21:48 ERROR]: #!#! at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
[21:21:48 ERROR]: #!#! at java.util.concurrent.FutureTask.run(FutureTask.java:266)
[21:21:48 ERROR]: #!#! at net.minecraft.server.v1_8_R1.MinecraftServer.z(MinecraftServer.java:656)
[21:21:48 ERROR]: #!#! at net.minecraft.server.v1_8_R1.DedicatedServer.z(DedicatedServer.java:284)
[21:21:48 ERROR]: #!#! at net.minecraft.server.v1_8_R1.MinecraftServer.y(MinecraftServer.java:609)
[21:21:48 ERROR]: #!#! at net.minecraft.server.v1_8_R1.MinecraftServer.run(MinecraftServer.java:517)
[21:21:48 ERROR]: #!#! at java.lang.Thread.run(Thread.java:748)
[21:21:48 ERROR]: #!#!
[21:21:48 ERROR]: #!#! Version Information:
[21:21:48 ERROR]: #!#! Skript: 2.1.2
[21:21:48 ERROR]: #!#! Bukkit: 1.8-R0.1-SNAPSHOT
[21:21:48 ERROR]: #!#! Minecraft: 1.8
[21:21:48 ERROR]: #!#! Java: 1.8.0_191
[21:21:48 ERROR]: #!#!
[21:21:48 ERROR]: #!#! Running CraftBukkit: false
[21:21:48 ERROR]: #!#!
[21:21:48 ERROR]: #!#! Current node: set {_f} to level of fortune of the player's tool/50 (drop.sk, line 483)
[21:21:48 ERROR]: #!#! Current item: null
[21:21:48 ERROR]: #!#!
[21:21:48 ERROR]: #!#! Thread: Server thread
[21:21:48 ERROR]: #!#!
[21:21:48 ERROR]: #!#! End of Error.

Zainstalowalem takie pluginy jak SkQuery, skUtilities czy wildskript

Skript to wersja 2.1.2

 

Proszę o szybką pomoc

 

Z góry dziękuje

Edytowane przez Bosuuu
Dopisanie

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Rekomendowane odpowiedzi

Użytkownik
  • 0

najprawdopodobniej jest to wina spowodowana przez którąś z addon'ów to skript'a

spróbuj usunąć wszystkie addon'y oraz zostaw tylko Skript

kiedyś miałem podobny error i okazało się że to była wina addon'ów, może masz je "przeterminowane" lub są nie na tą wersje skript'a

 

@Bosuuu

 

Edytowane przez TachiMC

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Użytkownik
  • 0
11 minut temu, TachiMC napisał:

najprawdopodobniej jest to wina spowodowana przez którąś z addon'ów to skript'a

spróbuj usunąć wszystkie addon'y oraz zostaw tylko Skript

kiedyś miałem podobny error i okazało się że to była wina addon'ów, może masz je "przeterminowane" lub są nie na tą wersje skript'a

 

@Bosuuu

 

Dalej nie działa :/

 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Użytkownik
  • 0
2 minuty temu, Bosuuu napisał:

Dalej nie działa :/

 

czy twój skrypt zawiera to w 483 linijce?

Cytat

set {_f} to level of fortune of the player's tool/50

 

@Bosuuu

 

Edytowane przez TachiMC

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Użytkownik
  • 0
5 minut temu, TachiMC napisał:

spróbuj usunąć tą linijkę

@Bosuuu

Usunąłem i dalej nic nie ruszyło

Teraz w konsoli jest taki komunikat

 

[21:56:41 INFO]: _Bosu_ issued server command: /skript reload all
[21:56:41 INFO]: [Metrics] Server returned HTTP response code: 504 for URL: Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!
[21:56:42 ERROR]: null
org.bukkit.command.CommandException: Unhandled exception executing command 'skript' in plugin Skript v2.1.2
at org.bukkit.command.PluginCommand.execute(PluginCommand.java:46) ~[craftbukkit-1.8.jar:git-Bukkit-7019900e]
at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:140) ~[craftbukkit-1.8.jar:git-Bukkit-7019900e]
at org.bukkit.craftbukkit.v1_8_R1.CraftServer.dispatchCommand(CraftServer.java:625) ~[craftbukkit-1.8.jar:git-Bukkit-7019900e]
at net.minecraft.server.v1_8_R1.PlayerConnection.handleCommand(PlayerConnection.java:1058) [craftbukkit-1.8.jar:git-Bukkit-7019900e]
at net.minecraft.server.v1_8_R1.PlayerConnection.a(PlayerConnection.java:919) [craftbukkit-1.8.jar:git-Bukkit-7019900e]
at net.minecraft.server.v1_8_R1.PacketPlayInChat.a(SourceFile:37) [craftbukkit-1.8.jar:git-Bukkit-7019900e]
at net.minecraft.server.v1_8_R1.PacketPlayInChat.a(SourceFile:9) [craftbukkit-1.8.jar:git-Bukkit-7019900e]
at net.minecraft.server.v1_8_R1.PacketHandleTask.run(SourceFile:13) [craftbukkit-1.8.jar:git-Bukkit-7019900e]
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_191]
at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_191]
at net.minecraft.server.v1_8_R1.MinecraftServer.z(MinecraftServer.java:656) [craftbukkit-1.8.jar:git-Bukkit-7019900e]
at net.minecraft.server.v1_8_R1.DedicatedServer.z(DedicatedServer.java:284) [craftbukkit-1.8.jar:git-Bukkit-7019900e]
at net.minecraft.server.v1_8_R1.MinecraftServer.y(MinecraftServer.java:609) [craftbukkit-1.8.jar:git-Bukkit-7019900e]
at net.minecraft.server.v1_8_R1.MinecraftServer.run(MinecraftServer.java:517) [craftbukkit-1.8.jar:git-Bukkit-7019900e]
at java.lang.Thread.run(Thread.java:748) [?:1.8.0_191]
Caused by: java.lang.NoSuchMethodError: ch.njol.util.NonNullPair.getSecond()Ljava/lang/Object;
at ch.njol.skript.command.Commands.loadCommand(Commands.java:379) ~[?:?]
at ch.njol.skript.ScriptLoader.loadScript(ScriptLoader.java:462) ~[?:?]
at ch.njol.skript.ScriptLoader.loadScripts(ScriptLoader.java:239) ~[?:?]
at ch.njol.skript.ScriptLoader.loadScripts(ScriptLoader.java:193) ~[?:?]
at ch.njol.skript.Skript.reload(Skript.java:548) ~[?:?]
at ch.njol.skript.SkriptCommand.onCommand(SkriptCommand.java:130) ~[?:?]
at org.bukkit.command.PluginCommand.execute(PluginCommand.java:44) ~[craftbukkit-1.8.jar:git-Bukkit-7019900e]
... 14 more

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Użytkownik
  • 0
Teraz, LuckyPotato napisał:

No wspaniale, to żyj sobie na tym swoim martwym bukkicie razem z takimi cudownymi błędami.

Masz może jakąś paczkę pluginów na spigota?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Użytkownik
  • 0
1 minutę temu, LuckyPotato napisał:

A ty masz może jakąś wyszukiwarkę internetową na komputerze? 

Ale mi chodzi o taką gotową paczkę.Średnio chce mi się szukać w necie

Edytowane przez Bosuuu

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Użytkownik
  • 0
1 minutę temu, Bosuuu napisał:

Ale mi chodzi o taką gotową paczkę.Średnio chce mi się szukać w necie

A co mnie to powiedz obchodzi? To tobie zależy nie mi, jak ci się nie chce to już twoja sprawa - nie będę szukał za ciebie.

Zainstalujesz Spigota i będą problemy to napisz, jak nie to odpuść bo innego sensownego rozwiązania tu nie dostaniesz. Do tego momentu rozmowę uważam za zakończoną.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Użytkownik
  • 0
Teraz, LuckyPotato napisał:

A co mnie to powiedz obchodzi? To tobie zależy nie mi, jak ci się nie chce to już twoja sprawa - nie będę szukał za ciebie.

Zainstalujesz Spigota i będą problemy to napisz, jak nie to odpuść bo innego sensownego rozwiązania tu nie dostaniesz. Do tego momentu rozmowę uważam za zakończoną.

Znasz się na spigocie?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Użytkownik
  • 0
45 minut temu, Bosuuu napisał:

Znasz się na spigocie?

Oczywiście, że są gotowe paczki na spigota. Wystarczy poszukać. :notlikethis:

Paczka pluginów na serwer 1.12.2 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Ten temat jest nieaktywny od dłuższego czasu. Nie odkopuj go bez potrzeby.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Losowy awatar
Odpowiedz na pytanie...

×   Wklejono zawartość z formatowaniem.   Usuń formatowanie

  Maksymalnie dozwolone są tylko 75 emotikony.

×   Odnośnik został automatycznie osadzony.   Przywróć wyświetlanie jako odnośnik

×   Przywrócono poprzednią zawartość.   Wyczyść edytor

×   Nie możesz bezpośrednio wkleić grafiki. Dodaj lub załącz grafiki z adresu URL.


  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×