Skocz do zawartości
  • 0

Problem z if


Gość KuzynProcesor
 Udostępnij

Pytanie

Gość KuzynProcesor

Witam,

pisze skrypt na ******** (tajemnica serwera ;P)

 

Macie tu fragment kodu. Proszę o korektę.

Variables:
	{druzyna::%player%} = 0 #2 teamy - DOBRZY & ZLI (ŹLI)
command /test:
	trigger:
		set {_druzynacwiczenia} to "%{druzyna::%sender%}%"
        if {_druzynacwiczenia} is %{druzyna::%loop-players%}%:
			send "&2>> Działa!"
        else:
        	send "&4>> Nie jesteś w Teamie sendera!"

Co robię źle? Co pamiętać na przyszłość (tak, wiem - dokumentacja ;P)

Edytowane przez KuzynProcesor
Odnośnik do komentarza
Udostępnij na innych stronach

6 odpowiedzi na to pytanie

Rekomendowane odpowiedzi

  • 0

źle wytabowane i wydaje mi się, że zbyt dużo %%

Variables:
	{druzyna::%player%} = 0
command /test:
	trigger:
		set {_druzynacwiczenia} to "%{druzyna::%sender%}%"
		if {_druzynacwiczenia} is {druzyna::%loop-players%}:
			send "&2>> Działa!"
		else:
			send "&4>> Nie jesteś w Teamie sendera!"

sprawdź i na przyszłość podaj błędy, nie mam magicznej kuli...

Odnośnik do komentarza
Udostępnij na innych stronach

  • 0
Gość KuzynProcesor

Akurat w skrypcie mam wytabowanie dobrze.

Error:

There's no loop that matches 'loop-players' (komendy.sk, line 273: if {_druzynacwiczenia} is {druzyna::%loop-players%}:')

 

Odnośnik do komentarza
Udostępnij na innych stronach

  • 0

Jeżeli to jest cały skrypt to [nie jest, line 273 zdradza wszystko - dop. red.] brakuje loopowania graczy:

Variables:
	{druzyna::%player%} = 0
command /test:
	trigger:
		set {_druzynacwiczenia} to "%{druzyna::%sender%}%"
		loop all players:
			if {_druzynacwiczenia} is {druzyna::%loop-players%}:
				send "&2>> Działa!"
			else:
				send "&4>> Nie jesteś w Teamie sendera!"

sprawdź

Edytowane przez xVendrome
Odnośnik do komentarza
Udostępnij na innych stronach

  • 0
Gość KuzynProcesor

Ale jest problem. Jakiś na czerwono "preforming command" czy cuś

MAcie cały skrypt bez zmiennych:

Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!

Cmd na wybranie teamu działa no problemu.

Nie ma jej w skrypcie

@ref

Edytowane przez KuzynProcesor
Odnośnik do komentarza
Udostępnij na innych stronach

Nieaktywny
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.
 Udostępnij

  • Ostatnio przeglądający   0 użytkowników

    • Brak zarejestrowanych użytkowników przeglądających tę stronę.
×
×
  • Dodaj nową pozycję...