Skocz do zawartości
  • 0
Polski Sześcian

Problem z modyfikacją DenseOres na wersji 1.10.2.

Pytanie

Użytkownik

Witam, tworzyłem paczkę modów i chciałem użyć modyfikacji DenseOres. Znalazłem tylko wersję 1.0.2 która obsługuje wersję 1.9.4, 1.10, 1.10.1, 1.10.2, 1.11, 1.11.1, 1.11.2. Tak wiem, napisałem że obsługuje 1.10.2, ale chyba tylko wg twórcy. Moglibyście powiedzieć w czym tkwi problem? Tu jest część loga w której występuj błąd :v. Tak, problemem jest crash.

// You should try our sister game, Minceraft!

Time: 8/15/17 12:35 PM
Description: There was a severe problem during mod loading that has caused the game to fail

net.minecraftforge.fml.common.LoaderExceptionModCrash: Caught exception from denseores (denseores)
Caused by: java.lang.NoSuchMethodError: net.minecraft.item.ItemStack.func_190926_b()Z
	at mcjty.lib.tools.ItemStackTools.isValid(ItemStackTools.java:64)
	at com.rwtema.denseores.compat.CompatLayer.isValid(CompatLayer.java:46)
	at com.rwtema.denseores.ModIntegration.getFurnace(ModIntegration.java:125)
	at com.rwtema.denseores.ModIntegration$VanillaFurnace.registerOre(ModIntegration.java:173)
	at com.rwtema.denseores.ModIntegration.addModIntegration(ModIntegration.java:155)
	at com.rwtema.denseores.DenseOresMod.init(DenseOresMod.java:126)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at net.minecraftforge.fml.common.FMLModContainer.handleModStateEvent(FMLModContainer.java:616)
	at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at com.google.common.eventbus.EventSubscriber.handleEvent(EventSubscriber.java:74)
	at com.google.common.eventbus.SynchronizedEventSubscriber.handleEvent(SynchronizedEventSubscriber.java:47)
	at com.google.common.eventbus.EventBus.dispatch(EventBus.java:322)
	at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:304)
	at com.google.common.eventbus.EventBus.post(EventBus.java:275)
	at net.minecraftforge.fml.common.LoadController.sendEventToModContainer(LoadController.java:243)
	at net.minecraftforge.fml.common.LoadController.propogateStateMessage(LoadController.java:221)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at com.google.common.eventbus.EventSubscriber.handleEvent(EventSubscriber.java:74)
	at com.google.common.eventbus.SynchronizedEventSubscriber.handleEvent(SynchronizedEventSubscriber.java:47)
	at com.google.common.eventbus.EventBus.dispatch(EventBus.java:322)
	at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:304)
	at com.google.common.eventbus.EventBus.post(EventBus.java:275)
	at net.minecraftforge.fml.common.LoadController.distributeStateMessage(LoadController.java:145)
	at net.minecraftforge.fml.common.Loader.initializeMods(Loader.java:805)
	at net.minecraftforge.fml.client.FMLClientHandler.finishMinecraftLoading(FMLClientHandler.java:334)
	at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:520)
	at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:351)
	at net.minecraft.client.main.Main.main(SourceFile:124)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
	at net.minecraft.launchwrapper.Launch.main(Launch.java:28)


A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------
-- System Details --
Details:
	Minecraft Version: 1.10.2
	Operating System: Windows 10 (amd64) version 10.0
	Java Version: 1.8.0_141, Oracle Corporation
	Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
	Memory: 1120484936 bytes (1068 MB) / 2224029696 bytes (2121 MB) up to 2863661056 bytes (2731 MB)
	JVM Flags: 3 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx3G -Xms1500M
	IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
	FML: MCP 9.32 Powered by Forge 12.18.3.2281 Optifine OptiFine_1.10.2_HD_U_E3 51 mods loaded, 51 mods active
	States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored
########Tu gdzie nie było na końcu E to usunąłem żeby nikt mi paczki modów nie przywłaszczył xD. ('E' = Errored)#########
	UCHE	denseores{1.0} [denseores] (DenseOres (1.10.2).jar)

Więcej rzeczy które odpowiadają za błąd nie ma :( 

//Edit:

Forge 12.18.3.2281

Ilość modów (całkiem nie wiem po co) (oczywiście licząc z denseores): 50

Źródło pobierania: Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!

 

//Edit:

Czy do DenseOres trzeba jakąś bibliotekę dodatkową pobrać?

Czy DenseOres wymaga wyższej wersji Forge albo jest niekompatybilny z innym modem?

Edytowane przez Polski Sześcian

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

5 odpowiedzi na to pytanie

Rekomendowane odpowiedzi

Użytkownik
  • 0

Chyba to nie jest chyba wina wersji moda bo mod by chyba działał (załadowywał się) nawet jak by był na wersji 1.2.5 a wersja minecraft'a była 1.12 ale by nie działały jego funkcje :v Raczej to jest wina kodu moda a nie wersji mc :v

 

Ale może to nie jest prawda, gdyż nie znam się :v 

 

Edytowane przez McKoxu

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Użytkownik
  • 0
9 godzin temu, McKoxu napisał:

Chyba to nie jest chyba wina wersji moda bo mod by chyba działał (załadowywał się) nawet jak by był na wersji 1.2.5 a wersja minecraft'a była 1.12 ale by nie działały jego funkcje :v Raczej to jest wina kodu moda a nie wersji mc :v

Ale autor twierdzi że powinien działać na 1.10.2 :v 

 

//Edit: Testowałem wszystkie wersje tego moda :v i też nie wchodziły na 1.10.2

Edytowane przez Polski Sześcian

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Użytkownik
  • 0
5 minut temu, Polski Sześcian napisał:

Ale autor twierdzi że powinien działać na 1.10.2 :v 

Pobierałeś tego moda z curse forge czy z jakiejś innej strony ?

Edytowane przez McKoxu

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Użytkownik
  • 0

Przeczytaj co jest na końcu tematu napisane :D 

9 godzin temu, Polski Sześcian napisał:

Źródło pobierania: Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!

Edit: Ale patrz, tu niby nie ma napisanego nic o 1.10.2: Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!

Edit: Do zamknięcia... Obczaiłem... CompatLayer jest na 1.10x.. Na 1.10 nie ma DenseOres..

Edytowane przez Polski Sześcian

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Losowy awatar
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.

  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×