Skocz do zawartości
  • 0

Spigot 1.7 - 1.8


ejer
 Udostępnij

Pytanie

Od jakiegoś dłuższego czasu (na hostingu enderchest) wyświetla się powiadomienie o tym że wersja 1.7.2 Bukkit jest odradzana. W związku z tym chciał bym przejść na proponowaną wersję: 1.7 - 1.8 Spigot. Natomiast obawiam się że niektóre pluginy mogły by nie funkcjonować. Większość to pluginy autorskie więc nie mam pewności że będą działać po zmianie wersji. Boję się że jak wejdę z 1.8 to pluginy przystosowane do 1.7 będą wariować albo nawet nie działać.

Odnośnik do komentarza
Udostępnij na innych stronach

3 odpowiedzi na to pytanie

Rekomendowane odpowiedzi

  • 0
Teraz, ejer napisał:

Boję się że jak wejdę z 1.8 to pluginy przystosowane do 1.7 będą wariować albo nawet nie działać.

Takie silniki cały czas działają na 1.7, a kiedy klient wejdzie z 1.8 po prostu przesyłają do niego nieco inne pakiety.

W praktyce jest tylko jeden sposób, żeby się przekonać - uruchom serwer na nowym silniku i zobacz co się stanie.

Odnośnik do komentarza
Udostępnij na innych stronach

  • 0
Dnia 16.10.2016 o 09:55, Libter napisał:

jest tylko jeden sposób, żeby się przekonać - uruchom serwer na nowym silniku i zobacz co się stanie

Wszystko działa... Tylko tablista z FunnyGulds nie działa poprawnie oraz nie widać hologramów z Holographics Displays...

Mam też plugin (nie publiczny) na antylogout i pasek bossa z antylogouta nie działa... tzn. widać go troche ale potem znika i sie pojawia i tak mruga powoli...

Odnośnik do komentarza
Udostępnij na innych stronach

  • 0

Na początku chłopie to musisz wiedzieć co to Spigot a CraftBukkit

Na chłopski rozum wytłumacze

CraftBukkit - ten gorszy

Spigot - ten lepszy

Spigot będzie działał Ci na serwerze prawidłowo i daje sobie rękę uciąć poniewaz to on jest obecnie najbardziej kompatybilnym silnikiem serwerów, wspieranym oraz dobrze odbieranym przez społeczność developerów. Musisz pamiętać że wersja gry spigota a craftbukkita to JEDNO I TO SAMO, tylko wersja po prostu (ich wersja) wiadomo bedzie różna (bo wprowadzają bugfixy itp)

Więc jeśli serwer masz przykładowo na wersji 1.8 - craftbukkit

I przejdziesz na serwer w wersji 1.8 - spigot

Pamiętaj że pluginy tylko muszą być zaktualizowane z najnowszą wersją pod daną wersje silnika 

To nic absolutnie się nie stanie, wszystko będzie funkcjonować poprawnie i stabilnie, oraz kompatybilnie z serwerem

Ja nawet Ci wręcz polecam aby wgrać spigota, jest wydajniejszy, lepszy, wspierany, rekomendowany.

To tyle.

Odnośnik do komentarza
Udostępnij na innych stronach

Nieaktywny
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.
 Udostępnij

  • Ostatnio przeglądający   0 użytkowników

    • Brak zarejestrowanych użytkowników przeglądających tę stronę.
×
×
  • Dodaj nową pozycję...