Skocz do zawartości
  • 0

Możliwość wejścia tylko z 1 wersji Minecraft


creepek

Pytanie

Witam,

Posiadam serwer na wersję 1.7.x-1.8.x ale chciałbym aby mogli wchodzić gracze tylko z 1.8.

Zmiana wersji na 1.8 nie pomoże bo mam napisane specjalnie dla mnie pluginy na 1.7.

Ale do rzeczy...

Proszę o skrypt który pozwoli wchodzić graczom tylko z wersji 1.8, dziękuję! <3

 

//Dodatkowo edytuję nazwę tematu @JPablo

Edytowane przez JPablo
Odnośnik do komentarza
Udostępnij na innych stronach

7 odpowiedzi na to pytanie

Rekomendowane odpowiedzi

  • 0

on join:

<tab>if player's version is "1.7.2":

<tab><tab>kick player due to "Zmien wersje na 1.8!" 

Nie sądze, żeby to coś zmieniło ale zawsze można spróbować. 

Odnośnik do komentarza
Udostępnij na innych stronach

  • 0

Ewald troszkę pomieszałeś

Tutaj dokumentacja z SkUnity:

on join:
    if minecraft version of player is "1.9":
        send "You're joining with version %mc version of player%!"

Więc dla Ciebie powinno to wyglądać tak:

on join:
    if minecraft version of player is "1.8":
        stop
    else:
        kick player due to "&cNiestety, serwer akceptuje tylko werrsję &a1.8" 

Daje to logiczne tłumaczenie:

Jeżeli wersja Minecraft Gracza to 1.8 > wykonaj

 

Twój kod

Jeżeli wersja Gracza to 1.8 > wykonaj kod ( tylko wersja czego, kody są logiczne a nie domyślne :) więc nie mogą one się domyślić czego wersja, zawsze trzeba im twardo określać co i jak przynajmniej tak nas w technikum uczyli na IT)

Edytowane przez JPablo
Odnośnik do komentarza
Udostępnij na innych stronach

  • 0
3 godziny temu, JPablo napisał:

Ewald troszkę pomieszałeś

Tutaj dokumentacja z SkUnity:


on join:
    if minecraft version of player is "1.9":
        send "You're joining with version %mc version of player%!"

Więc dla Ciebie powinno to wyglądać tak:


on join:
    if minecraft version of player is "1.8":
        stop
    else:
        kick player due to "&cNiestety, serwer akceptuje tylko werrsję &a1.8" 

Daje to logiczne tłumaczenie:

Jeżeli wersja Minecraft Gracza to 1.8 > wykonaj

 

Twój kod

Jeżeli wersja Gracza to 1.8 > wykonaj kod ( tylko wersja czego, kody są logiczne a nie domyślne :) więc nie mogą one się domyślić czego wersja, zawsze trzeba im twardo określać co i jak przynajmniej tak nas w technikum uczyli na IT)

 

Odnośnik do komentarza
Udostępnij na innych stronach

Nieaktywny
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.
  • Ostatnio przeglądający   0 użytkowników

    • Brak zarejestrowanych użytkowników przeglądających tę stronę.
×
×
  • Dodaj nową pozycję...