Skocz do zawartości
  • 0

Problem z regionami


shiworld
 Udostępnij

Pytanie

Witam

 

W swoim poprzednim temacie o innej sprawie napisałem w ostatnim poście, że mam jeszcze inny problem, ale temat zamknięty :)

 

Nie chce mi działać następująca komenda:

command /setbaza:    trigger:        if {gildia.%name of player%.owner} is true:            set {_region} to Region.at{location of player};            if {_region} is "gildia-%{gildia.tag.%player%}%":                set {gildia.%{gildia.tag.%name of player%}%.dom} to location of player                send "&9Baza twojej gildii zostala ustawiona!"                stop            else:                send "&9Baze mozesz ustawic tylko na terenie swojej gildii!"                stop        else:            send "&9Nie posiadasz gildii!"            stop

Znaczy.. komenda sama działa, ale coś jest z regionami. Gdy wpisuję komendę wyskakuje mi tylko "Baze mozesz ustawic tylko na terenie swojej gildii!".

 

Jeśli ktoś wie jak to naprawić, proszę o szybką pomoc! :(

Odnośnik do komentarza
Udostępnij na innych stronach

2 odpowiedzi na to pytanie

Rekomendowane odpowiedzi

  • 0

Sprawdź czy wcześniej dobrze ustawiasz {region.%name of player%.owner} bo tutaj nie ma żadnego regionu, sprawdzasz tylko czy to jest ustawione, ale nie do jakiego regionu

@edit podaj kod jak tworzysz region i ustalasz właściciela

《☆》Wysłane z SGS4 przy użyciu tapatalk.

Odnośnik do komentarza
Udostępnij na innych stronach

Nieaktywny
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.
 Udostępnij

  • Ostatnio przeglądający   0 użytkowników

    • Brak zarejestrowanych użytkowników przeglądających tę stronę.
×
×
  • Dodaj nową pozycję...