Skocz do zawartości
  • 0

Pliki yml etc


szaphi
 Udostępnij

Pytanie

dlaczego nie działa mi "if file "plugins/Skript/skripts/Bankkonta/%player%.yml" doesn't exists:"

dokładnie pokazuje mi 
zBNiSy7.png



a tutaj cały kod 
 

command /bank [<player>]:
    aliases: stan , konto
    trigger:
        if arg 1 is not set:
            if {stanbank::%player%} is not set:
                if file "plugins/Skript/skripts/Bankkonta/%player%.yml" doesn't exists:
                    create file "Bankkonta/%player%.yml"
                    set {stanbank::%player%} to 5000
                    set "b.stanbank" to "%{stanbank::%player%}%" in yaml file "Bankkonta/%player%.yml"
                    send "&aBank &7>> &6Twoje konto w banku zostało założone!"
                    stop
                if {stanbank::%player%} is set:
                    send "&7[&aBank&7] &7>> &6Twój stan konta to &a%{stanbank::%player%}%$"
                    stop

 

Edytowane przez Wojciu
Odnośnik do odpowiedzi
Udostępnij na innych stronach

Rekomendowane odpowiedzi

  • 0

 

34 minuty temu, Kormic napisał:

 

Spróbuj użyć tego, zobaczymy czy zadziała. Powinien ci się utworzyć plik test.yml i powinna pojawić ci się w nim zmienna "test" z wartością "Działa!", a zaraz po tym powinien być broadcast.

Zrobiłem taki skrypt i mi działa, dałem sender, ponieważ testowałem z konsoli, ale jestem pewien, że można to zastąpić, więc zainspiruj się tym i zobaczymy.

Spróbuj, zrobiłem skrypt, powinien działać.

Z ciekawości sprawdziłem, i gdzieś chyba mam za długi tor ponieważ nie tworzy mi się w scripts tylko w folderze "serwer" gdzie trzymam silnik... Nie wiem dlaczego tak :O

Ale jak testowałem to twoje, to normalnie mi zrobiło test tam gdzie miało, czyli folder Bankkonta

 

Edytowane przez szaphi
Odnośnik do odpowiedzi
Udostępnij na innych stronach

  • 0
3 minuty temu, szaphi napisał:

 

Z ciekawości sprawdziłem, i gdzieś chyba mam za długi tor ponieważ nie tworzy mi się w scripts tylko w folderze "serwer" gdzie trzymam silnik... Nie wiem dlaczego tak :O

Ale jak testowałem to twoje, to normalnie mi zrobiło test tam gdzie miało, czyli folder Bankkonta

 

Czyli problem rozwiązany?

Odnośnik do odpowiedzi
Udostępnij na innych stronach

  • 0
Teraz, Kormic napisał:

Czyli problem rozwiązany?

Tak teoretycznie tak, ale teraz mam kolejny problem który sobie rozwiąże, i możliwe, że będę pisał kolejne tematy bo mam problem z jednym skryptem, ale to chyba ogarnę :D 

Odnośnik do odpowiedzi
Udostępnij na innych stronach

  • 0
Teraz, szaphi napisał:

Tak teoretycznie tak, ale teraz mam kolejny problem który sobie rozwiąże, i możliwe, że będę pisał kolejne tematy bo mam problem z jednym skryptem, ale to chyba ogarnę :D 

W takim razie okej, możesz zawsze do mnie napisać na PW, postaram się pomóc.

Odnośnik do odpowiedzi
Udostępnij na innych stronach

Nieaktywny
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.
 Udostępnij

  • Ostatnio przeglądający   0 użytkowników

    • Brak zarejestrowanych użytkowników przeglądających tę stronę.
×
×
  • Dodaj nową pozycję...