Skocz do zawartości
  • 0

Skrypt Bob Budowniczy


xVelu
 Udostępnij

Pytanie

Witam! Otóż mam problem ze skryptem, który buduje "budowle". Problem jest w tym że nie pisze on na czacie podczas budowania. Skrypt jest przygotowany do dodania większej ilości budowli. za błędy ortograficzne przepraszam lecz jestem zmęczony.

Kod:

command /build [<text>]:
    trigger:
        open chest with 3 rows named "GUI 1" to player
        format slot 0 of player with arrow named "" with lore "1" to close then run "skriptgui2 1"
    
command /skriptgui2 [<text>]:
    trigger:
        if argument 1 is "1":
            send "&8[&f13&8] &fTrwa Budowanie budowli &c13&7.mc" to player
            wait 3 ticks
            execute console command "setblock -92 109 250 quartz_block"
            wait 12 ticks
            send "&8[&f13&8] &fUkonczono &22 &fprocent." to player
            wait 3 ticks
            execute console command "setblock -92 110 250 quartz_block"
            wait 12 ticks
            send "&8[&f13&8] &fUkonczono &24 &fprocent." to player
            wait 3 ticks
            execute console command "setblock -92 111 250 quartz_block"
            wait 12 ticks
            send "&8[&f13&8] &fUkonczono &26 &fprocent." to player
            wait 3 ticks
            execute console command "setblock -92 112 250 quartz_block"
            wait 12 ticks
            send "&8[&f13&8] &fUkonczono &28 &fprocent." to player
            wait 3 ticks
            execute console command "setblock -92 113 250 quartz_block"
            wait 12 ticks
            send "&8[&f13&8] &fUkonczono &210 &fprocent." to player
            wait 3 ticks
            execute console command "setblock -92 114 250 quartz_block"

 

Edytowane przez Wojciu
Wojciu

Poprawiam formatowanie i kod wstawiam w code.

Notatka dodana przez Wojciu

Odnośnik do odpowiedzi
Udostępnij na innych stronach

9 odpowiedzi na to pytanie

Rekomendowane odpowiedzi

  • 0

Proszę, powinno działać. I kilka uwag:

1. Nie używaj format slot, a set slot

2. Zamiast używać komend poprzez konsolę używaj składni Skripta, jeżeli to jest niemożliwe, rozważ przynajmniej wykonywanie poprzez gracza.

Odnośnik do odpowiedzi
Udostępnij na innych stronach

  • 0
2 minuty temu, xVelu napisał:

teraz wogóle nie dziala

Działa działa, testowałem 😃

2 minuty temu, Kormic napisał:

Proszę, powinno działać. I kilka uwag:

1. Nie używaj format slot, a set slot

2. Zamiast używać komend poprzez konsolę używaj składni Skripta, jeżeli to jest niemożliwe, rozważ przynajmniej wykonywanie poprzez gracza.

Kolega to lepiej zrobił 🙂

Odnośnik do odpowiedzi
Udostępnij na innych stronach

  • 0
21 minut temu, Kormic napisał:

Proszę, powinno działać. I kilka uwag:

1. Nie używaj format slot, a set slot

2. Zamiast używać komend poprzez konsolę używaj składni Skripta, jeżeli to jest niemożliwe, rozważ przynajmniej wykonywanie poprzez gracza.

set slot nie dzialal poprawilem na format bo tylko tak dziala TuSKe mam

\

 

Edytowane przez xVelu
Odnośnik do odpowiedzi
Udostępnij na innych stronach

  • 0
1 minutę temu, xVelu napisał:

set slot nie dzialal poprawilem na format bo tylko tak dziala TuSKe mam

\

 

U mnie wszystko ładnie działa, więc problem jest po twojej stronie. Format slot jest zbugowany, dlatego mimo wszystko zalecam używanie set slot. Sprawdź TuSKe i Skripta, być może masz starszą wersję, przeładuj skrypt poprzez konsolę i sprawdź, czy nie masz jakichś błędów. Jeżeli mimo wszystko to nie będzie działało (a to by było naprawdę dziwne), to już użyj tego format slota.

Odnośnik do odpowiedzi
Udostępnij na innych stronach

Nieaktywny
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.
 Udostępnij

  • Ostatnio przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×
×
  • Dodaj nową pozycję...