Skocz do zawartości

Jeden serwer - wiele wersji [1.7 - 1.17]


jaku49
 Udostępnij

Rekomendowane odpowiedzi

  

8aVvxa2.png


Czy zastanawiałeś się kiedyś na stworzeniem serwera, na który będą mogli wchodzić gracze na różnych wersjach?
Dobrze trafiłeś, w dzisiejszym poradniku przybliżę Ci serię plug-in’ów Via, a dokładnie ViaVersionViaBackwards oraz ViaRewind.
JMoYspP.pngUw92NPA.png


ViaVersion – dodaje wsparcie dla nowych wersji, gdy serwer stoi na starszej (np. 1.12 wtedy gracze mogą dołączyć z wersji 1.16 lub 1.17)
ViaBackwards – dodaje połączenia „wstecz” dla serwerów stojących na nowych wersjach (np. 1.12), czyli gracze mogą dołączyć na wersjach 1.9 – 1.12. Plugin jest kompatybilny z wersją 1.17.
ViaRewind – dodaje połączenia dla graczy z wersji 1.7 oraz 1.8, gdy serwer stoi na wyższych wersjach. Plugin jest kompatybilny z wersją 1.17.
vFDnEWO.png 
Jeśli chcesz, aby serwer był dostępny dla graczy z wersji 1.7 – 1.16, najlepiej postawić go na wersji 1.8, ale jest tego wada, a są nią stare pluginy i liczne błędy.
Gdy serwer będzie uruchomimy na wersji 1.16, a będziemy chcieli, aby gracze mogli dołączyć z starszych wersji, musisz użyć ViaBackwards (wsparcie dla nowszych od 1.9) oraz ViaRewind (wsparcie do wersji 1.7 i 1.8). 
Oczywiście nie trzeba wspominać, że to rozwiązanie pobiera trochę pamięci RAM. Nie zaleca się również stosować komendy /reload, ponieważ spowoduje ona wysokie obciążenie serwera i serwer może się wyłączyć.
Istnieje również dodatek dodający wsparcie dla wersji 1.7 czyli ViaRewind działa on w porozumieniu z ViaBackwards
6JQ5wfl.png

/viaver list – lista graczy na odpowiednich wersjach,
/viaver dontbugme – włącza informacje o aktualizacji pluginu,
/viaver autoteam – włącza kolizje między graczami,
/viaver pps – wyświetla ilość wysyłanych pakietów przez danego gracza,
/viaver debug – nie należy używać, ale służy do wyświetlania wszystkich wysyłanych przez gracza pakietów w konsoli.

Instalacja plug-inów przebiega w standardowy sposób, należy wkleić pliki .jar wtyczek do folderu /plugins.
cx2u5p5.png
roey7vY.png 
Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!
Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!
Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!
Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!
Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!

Poradnik jest własnością jaku49 (kubix03), był również publikowany na konkurencyjnym forum oraz blogu o tematyce Minecrafta.

 

Edytowane przez jaku49
aktualizacja do wersji 1.17
Odnośnik do odpowiedzi
Udostępnij na innych stronach

2 godziny temu, maxcom1Games napisał:

@jaku49, ale reload sie buguje lub nie działa przy których z wymienionych pluginów?

Gdy masz ProtocolSupport to wpisanie komendy powoduje wyświetlenie komunikatu że nie jest to możliwe, ponieważ  ten plugin to blokuje. A normalnie z Via powoduje to duży pobór pamięci ram po reloadzie ale mogą być też inne błędy. 

Odnośnik do odpowiedzi
Udostępnij na innych stronach

  • 2 tygodnie później...
  • 5 miesięcy temu...
15 godzin temu, _Of3k napisał:

<ukryta zawartość>

Via dostał update na 1.14.
Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!

niedługo zaktualizuję swój poradnik :) opisałem już to na blogu: Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!

Edytowane przez Mroczekk
Odnośnik do odpowiedzi
Udostępnij na innych stronach

W dniu 27.02.2019 o 16:39, jaku49 napisał:

Oczywiście nie trzeba wspominać, że to rozwiązanie pobiera trochę pamięci RAM

Osobiście uważam, że nie jest to coś oczywistego, szczególnie dla osób dopiero zaczynających z tym tematem lub nieprowadzących serwerów ze wsparciem poprzednich wersji, w tym mnie. Reszta poradnika, chociaż nie zagłębia on się zbytnio w szczegóły, nad czym bardzo ubolewam, ponieważ chciałbym poczytać trochę więcej na temat protokołów i sztuczek zastosowanych w tym rozwiązaniu, jest ok. 
 

Z wyrazami szacunku,
Kurotsuwa

Edytowane przez Kurotsuwa
Odnośnik do odpowiedzi
Udostępnij na innych stronach

W dniu 8.03.2019 o 18:45, Peridot napisał:

Jeżeli używasz /reload to już wiemy że nie za bardzo umiesz obchodzić się z serwer :rak:

 

O ile reload rzeczywiście powoduje kłopoty w wielu wypadkach, czasami jest jednak przydatny.

Odnośnik do odpowiedzi
Udostępnij na innych stronach

  • jaku49 zmienił(a) tytuł na Jeden serwer - wiele wersji [1.7 - 1.16]
  • jaku49 zmienił(a) tytuł na Jeden serwer - wiele wersji [1.7 - 1.17]

Dołącz do dyskusji

Możesz dodać zawartość już teraz a zarejestrować się później. Jeśli posiadasz już konto, zaloguj się aby dodać zawartość za jego pomocą.

Nieaktywny
Dodaj odpowiedź do tematu...

×   Wklejono zawartość z formatowaniem.   Usuń formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Odnośnik został automatycznie osadzony.   Przywróć wyświetlanie jako odnośnik

×   Przywrócono poprzednią zawartość.   Wyczyść edytor

×   Nie możesz bezpośrednio wkleić grafiki. Dodaj lub załącz grafiki z adresu URL.

 Udostępnij

  • Ostatnio przeglądający   0 użytkowników

    • Brak zarejestrowanych użytkowników przeglądających tę stronę.
×
×
  • Dodaj nową pozycję...