Skocz do zawartości
Rejszpat

SkriptPack v2.1 - Skript i dodatki do niego na 1.12.2

Rekomendowane odpowiedzi

Użytkownik

Witam. Chciałbym opublikować paczkę pluginów o nazwie „SkriptPack” ze Skriptem i dodatkami do niego, na 1.12.2.

Paczka zawiera:

Cytat

Skript_dev36

WildSkript_1.8.4

PirateSK_7.1b PirateSK_7.2infdev

Skellett_1.9.6b

SkQuery_3.6.0-Lime

skRayFall_1.9.12

SkStuff_1.6.4.1

skUtilities_0.9.2

Skungee_1.0.6a Skungee_1.0.6b

SkIris_1.12.2 - podziękowania dla @LloydPL :seemskappa:

MundoSK_1.8.2

TuSKe_1.8.2

skDragon_0.14.0

Conquer_1.3.1

IdkSk_1.2.1

QuarSk_1.3.1

SharpSK_1.6.3

SkAction_2.2

skript-mirror_0.16.0 skript-mirror_0.16.1

Drobne błędy:

- TuSKe ma drobną niekompatybilność z najnowszym Skriptem; teoretycznie nie przeszkadza to w niczym :V 

[21:30:23 ERROR]: #!#!
[21:30:23 ERROR]: #!#! [Skript] Severe Error:
[21:30:23 ERROR]: #!#! TuSKe's class com.github.tukenuke.tuske.effects.EffMakeDrop generated an exception while loading
[21:30:23 ERROR]: #!#!
[21:30:23 ERROR]: #!#! Something went horribly wrong with Skript.
[21:30:23 ERROR]: #!#! This issue is NOT your fault! You probably can't fix it yourself, either.
[21:30:23 ERROR]: #!#! It looks like you are using some plugin(s) that alter how Skript works (addons).
[21:30:23 ERROR]: #!#! Following plugins are probably related to this error in some way:
[21:30:23 ERROR]: #!#! TuSKe (github.com/Tuke-Nuke/TuSKe)
[21:30:23 ERROR]: #!#! You should try disabling those plugins one by one, trying to find which one causes it.
[21:30:23 ERROR]: #!#! If the error doesn't disappear even after disabling all listed plugins, it is probably Skript issue.
[21:30:23 ERROR]: #!#! In that case, you will be given instruction on how should you report it.
[21:30:23 ERROR]: #!#! On the other hand, if the error disappears when disabling some plugin, report it to author of that plugin.
[21:30:23 ERROR]: #!#! Only if the author tells you to do so, report it as Skript issue (url below)
[21:30:23 ERROR]: #!#! Issue tracker: https://github.com/SkriptLang/Skript/issues (only if you know what you're doing!)
[21:30:23 ERROR]: #!#!
[21:30:23 ERROR]: #!#! Stack trace:
[21:30:23 ERROR]: #!#! java.lang.NullPointerException
[21:30:23 ERROR]: #!#!     at com.github.tukenuke.tuske.effects.EffMakeDrop.<clinit>(EffMakeDrop.java:25)
[21:30:23 ERROR]: #!#!     at java.lang.Class.forName0(Native Method)
[21:30:23 ERROR]: #!#!     at java.lang.Class.forName(Unknown Source)
[21:30:23 ERROR]: #!#!     at ch.njol.skript.SkriptAddon.loadClasses(SkriptAddon.java:108)
[21:30:23 ERROR]: #!#!     at com.github.tukenuke.tuske.TuSKe.onEnable(TuSKe.java:100)
[21:30:23 ERROR]: #!#!     at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:264)
[21:30:23 ERROR]: #!#!     at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:337)
[21:30:23 ERROR]: #!#!     at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:403)
[21:30:23 ERROR]: #!#!     at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugin(CraftServer.java:381)
[21:30:23 ERROR]: #!#!     at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugins(CraftServer.java:330)
[21:30:23 ERROR]: #!#!     at net.minecraft.server.v1_12_R1.MinecraftServer.t(MinecraftServer.java:422)
[21:30:23 ERROR]: #!#!     at net.minecraft.server.v1_12_R1.MinecraftServer.l(MinecraftServer.java:383)
[21:30:23 ERROR]: #!#!     at net.minecraft.server.v1_12_R1.MinecraftServer.a(MinecraftServer.java:338)
[21:30:23 ERROR]: #!#!     at net.minecraft.server.v1_12_R1.DedicatedServer.init(DedicatedServer.java:272)
[21:30:23 ERROR]: #!#!     at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:545)
[21:30:23 ERROR]: #!#!     at java.lang.Thread.run(Unknown Source)
[21:30:23 ERROR]: #!#!
[21:30:23 ERROR]: #!#! Version Information:
[21:30:23 ERROR]: #!#!   Skript: 2.2-dev36
[21:30:23 ERROR]: #!#!   Bukkit: 1.12.2-R0.1-SNAPSHOT
[21:30:23 ERROR]: #!#!   Minecraft: 1.12.2
[21:30:23 ERROR]: #!#!   Java: 1.8.0_171 (Java HotSpot(TM) 64-Bit Server VM 25.171-b11)
[21:30:23 ERROR]: #!#!   OS: Windows 10 amd64 10.0
[21:30:23 ERROR]: #!#!
[21:30:23 ERROR]: #!#! Server platform: Spigot
[21:30:23 ERROR]: #!#!
[21:30:23 ERROR]: #!#! Current node: null
[21:30:23 ERROR]: #!#! Current item: null
[21:30:23 ERROR]: #!#!
[21:30:23 ERROR]: #!#! Thread: Server thread
[21:30:23 ERROR]: #!#!
[21:30:23 ERROR]: #!#! Language: english
[21:30:23 ERROR]: #!#! Link parse mode: DISABLED
[21:30:23 ERROR]: #!#!
[21:30:23 ERROR]: #!#! End of Error.
[21:30:23 ERROR]: #!#!

- Błąd updatera IdkSk

javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
	at sun.security.ssl.Alerts.getSSLException(Alerts.java:192) ~[?:1.8.0_66]
	at sun.security.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1949) ~[?:1.8.0_66]
	at sun.security.ssl.Handshaker.fatalSE(Handshaker.java:302) ~[?:1.8.0_66]
	at sun.security.ssl.Handshaker.fatalSE(Handshaker.java:296) ~[?:1.8.0_66]
	at sun.security.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1509) ~[?:1.8.0_66]
	at sun.security.ssl.ClientHandshaker.processMessage(ClientHandshaker.java:216) ~[?:1.8.0_66]
	at sun.security.ssl.Handshaker.processLoop(Handshaker.java:979) ~[?:1.8.0_66]
	at sun.security.ssl.Handshaker.process_record(Handshaker.java:914) ~[?:1.8.0_66]
	at sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:1062) ~[?:1.8.0_66]
	at sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1375) ~[?:1.8.0_66]
	at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1403) ~[?:1.8.0_66]
	at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1387) ~[?:1.8.0_66]
	at sun.net.www.protocol.https.HttpsClient.afterConnect(HttpsClient.java:559) ~[?:1.8.0_66]
	at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:185) ~[?:1.8.0_66]
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1513) ~[?:1.8.0_66]
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1441) ~[?:1.8.0_66]
	at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:254) ~[?:1.8.0_66]
	at java.net.URL.openStream(URL.java:1038) ~[?:1.8.0_66]
	at org.apache.commons.io.IOUtils.toString(IOUtils.java:1153) ~[spigot_1.12.2.jar:git-Spigot-642f6d2-6103339]
	at org.apache.commons.io.IOUtils.toString(IOUtils.java:1174) ~[spigot_1.12.2.jar:git-Spigot-642f6d2-6103339]
	at me.nicofisi.idksk.IdkSk$onEnable$1.run(IdkSk.kt:50) ~[?:?]
	at org.bukkit.craftbukkit.v1_12_R1.scheduler.CraftTask.run(CraftTask.java:76) ~[spigot_1.12.2.jar:git-Spigot-642f6d2-6103339]
	at org.bukkit.craftbukkit.v1_12_R1.scheduler.CraftAsyncTask.run(CraftAsyncTask.java:52) [spigot_1.12.2.jar:git-Spigot-642f6d2-6103339]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:1.8.0_66]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:1.8.0_66]
	at java.lang.Thread.run(Thread.java:745) [?:1.8.0_66]
Caused by: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
	at sun.security.validator.PKIXValidator.doBuild(PKIXValidator.java:387) ~[?:1.8.0_66]
	at sun.security.validator.PKIXValidator.engineValidate(PKIXValidator.java:292) ~[?:1.8.0_66]
	at sun.security.validator.Validator.validate(Validator.java:260) ~[?:1.8.0_66]
	at sun.security.ssl.X509TrustManagerImpl.validate(X509TrustManagerImpl.java:324) ~[?:1.8.0_66]
	at sun.security.ssl.X509TrustManagerImpl.checkTrusted(X509TrustManagerImpl.java:229) ~[?:1.8.0_66]
	at sun.security.ssl.X509TrustManagerImpl.checkServerTrusted(X509TrustManagerImpl.java:124) ~[?:1.8.0_66]
	at sun.security.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1491) ~[?:1.8.0_66]
	... 21 more
Caused by: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
	at sun.security.provider.certpath.SunCertPathBuilder.build(SunCertPathBuilder.java:146) ~[?:1.8.0_66]
	at sun.security.provider.certpath.SunCertPathBuilder.engineBuild(SunCertPathBuilder.java:131) ~[?:1.8.0_66]
	at java.security.cert.CertPathBuilder.build(CertPathBuilder.java:280) ~[?:1.8.0_66]
	at sun.security.validator.PKIXValidator.doBuild(PKIXValidator.java:382) ~[?:1.8.0_66]
	at sun.security.validator.PKIXValidator.engineValidate(PKIXValidator.java:292) ~[?:1.8.0_66]
	at sun.security.validator.Validator.validate(Validator.java:260) ~[?:1.8.0_66]
	at sun.security.ssl.X509TrustManagerImpl.validate(X509TrustManagerImpl.java:324) ~[?:1.8.0_66]
	at sun.security.ssl.X509TrustManagerImpl.checkTrusted(X509TrustManagerImpl.java:229) ~[?:1.8.0_66]
	at sun.security.ssl.X509TrustManagerImpl.checkServerTrusted(X509TrustManagerImpl.java:124) ~[?:1.8.0_66]
	at sun.security.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1491) ~[?:1.8.0_66]
	... 21 more

Paczka będzie regularnie aktualizowana.

Pobierz: 

Cytat

Download: Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!

Cytat

Skan: Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!

Changelog:

Spoiler
Spoiler

 

Czerwiec 2018

12.06.2018 20:47 - pierwsza wersja SkriptPack. Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!

13.06.2018 21:30 - wszystko aktualne. 

13.06.2018 21:37 - dodaje Skungee. Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!

14.06.2018 15:13 - wszystko aktualne.

15.06.2018 19:35 - wszystko aktualne.

16.06.2018 15:32 - wszystko aktualne.

17.06.2018 11:06 - wszystko aktualne.

17.06.2018 11:25 - dodaje SkIris. Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!

17.06.2018 11:42 - dodaje MundoSK. Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!

17.06.2018 11:50 - dodaje TuSKe. Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!

18.06.2018 21:30 - aktualizuje Skungee. Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!

19.06.2018 06:50 - wszystko aktualne.

20.06.2018 18:21 - wszystko aktualne.

21.06.2018 15:30 - wszystko aktualne.

22.06.2018 22:05 - dodaję skDragon; aktualizuje PirateSK. Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!

23.06.2018 19:34 - wszystko aktualne.

24.06.2018 16:55 - wszystko aktualne.

25.06.2018 16:00 - wszystko aktualne.

26.06.2018 22:40 - wszystko aktualne.

27.06.2018 10:02 - wszystko aktualne.

28.06.2018 08:48  - wszystko aktualne.

29.06.2018 08:07 - wszystko aktualne.

30.06.2018 13:13 - wszystko aktualne.

Lipiec 2018

01.07.2018 - „An interesting update”. Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!

02.07.2018 - wszystko aktualne.

03.07.2018 - wszystko aktualne.

03.07.2018 - aktualizuje skript-mirror. Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!

04.07.2018 - wszystko aktualne.

05.07.2018 - wszystko aktualne.

06.07.2018 - wszystko aktualne.

07.07.2018 - wszystko aktualne.

Log włączania serwera po wgraniu najnowszego SkriptPack'a: 

Support w razie niedziałania/błędów paczki (godziny pracy: poniedziałek-piątek: 18:30-22:00; sobota-niedziela: 14:30-22:00; święta: zamknięte :santakappa:)Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!

Edytowane przez Rejszpat

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Użytkownik

No, wszystko spoko poza tym że serwer rozwalony: już mówie co crashuje: xD

  • MundoSK
  • PirateSK
  • Skellet [brak eventu SpawnerSpawnEvent]
  • Sklris [brak eventu SpawnerSpawnEvent, podobnie jak powyżej, ciekawe.... :P]

Gram na 1.12.2 bez żadnych haków protokołów, wersja paczki v5.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Użytkownik
Godzinę temu, NorteX napisał:

No, wszystko spoko poza tym że serwer rozwalony: już mówie co crashuje: xD

  • MundoSK
  • PirateSK
  • Skellet [brak eventu SpawnerSpawnEvent]
  • Sklris [brak eventu SpawnerSpawnEvent, podobnie jak powyżej, ciekawe.... :P]

Gram na 1.12.2 bez żadnych haków protokołów, wersja paczki v5.

Przykro mi, ale u mnie wszystko działa. Może potrzebujesz Javy 8 na serwerze.
Oto log z włączania serwera, ze świeżo wgranymi pluginami, bez wygenerowanych folderów:
Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!

Napisz na serwerze Discord supportu paczki Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść! @NorteX

Edytowane przez Rejszpat

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Użytkownik

 Poza tym mam jeszcze te takie podstawowe pluginy:

EssentialsX, EssentialsXspawn, EssentialsXchat, PEX, WE, WG i Vault Tylko te 4 crashują -,-

Edit: mam jave 8

Edytowane przez NorteX

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Użytkownik
4 godziny temu, NorteX napisał:

 Poza tym mam jeszcze te takie podstawowe pluginy:

EssentialsX, EssentialsXspawn, EssentialsXchat, PEX, WE, WG i Vault Tylko te 4 crashują -,-

Edit: mam jave 8

Daj na Discordzie supportu log ładowania serwera.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Użytkownik

Fajnie że wszystko w jednym miejscu, dla początkujących to na pewno spore ułatwienie bo są tacy co korzystają z tego Skript'a ze strony bukkit'a bo nie wiedzą że BENSKU to dalej rozwija :) 

 

POLECAM jaku49

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Użytkownik

Ma ktoś propozycję na dodanie jakiegoś addona do paczki?

30.06.2018

Właśnie dziś zakończyliśmy aktualizację paczki na ten miesiąc :D 
Jutro będzie prawdopodobnie jakaś aktualizacja, która wniesie do paczki nowe pluginy, będące addonami do Skripta :> 

Edytowane przez Rejszpat

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Użytkownik

Zapraszam wszystkich do pobrania najnowszej wersji SkriptPacka! Wyszedł właśnie "An interesting update" :kappa:.

Ta aktualizacja wprowadziła do paczki:

  • Conquer_1.3.1
  • IdkSk_1.2.1
  • QuarSk_1.3.1
  • SharpSK_1.6.3
  • SkAction_2.2
  • skript-mirror_0.16.0

Mam nadzieję, że aktualizacja wszystkim się spodobała :).

W razie jakichkolwiek błędów proszę o kontakt na serwerze Discord: Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!

Edytowane przez Rejszpat

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Użytkownik

Bardzo fajnie że dałeś tą paczkę ale mam z nią problem.

Kupiłem serwer na endercheście (testowy) 1.12.2 bukkit i sobie ogarniałem skrypty potem wszystkie skrypty przeniosłem na mój drugi serwer na titanaxe gdzie tylko Skript wywala error

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Użytkownik
2 godziny temu, Treloog napisał:

Bardzo fajnie że dałeś tą paczkę ale mam z nią problem.

Kupiłem serwer na endercheście (testowy) 1.12.2 bukkit i sobie ogarniałem skrypty potem wszystkie skrypty przeniosłem na mój drugi serwer na titanaxe gdzie tylko Skript wywala error

Napisz na supporcie, który znajduje się na Discordzie Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!; załącz log błędu.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×