Skocz do zawartości
BloodyMen

chat BM-AntyReklama - skrypt na antyreklamę

Recommended Posts

Użytkownik

Siema, mam do zaprezętowania Skript na AntyReklame.

Autor: BloodyMen (JA)

Versja: 1.0.0

Skript napisany na szybko wiec dupy nie urywa, lecz mysle ze nadaje sie do uzytku :)

Zasada Dzialania:

Jesli gracz wysle na czacie wiadomosc ktora moze byc reklama, typu "Zapraszam na nowy serwer MojeIP.pl!"

Wiadomosc nie zostanie wyslana, a kazdy administrator online otrzyma informacje o reklama z mozliwoscia zbanowania gracza.

Potrzebne pluginy: Skript, SkQuery

PasteBin: Zarejestruj się lub zaloguj, aby zobaczyć ukrytą treść!  (Już poprawione)

Reklama.png

Edytowane przez BloodyMen

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach
Użytkownik

Jezu czy serio nie rozumiecie ze napisane na szybko? Jest napewno lepszy niż jakies poprostu blokowanie... Osoba ktore pisza "kolejna antty reklama" .. "pisane w 1 sek" to idioci...

Edytowane przez BloodyMen

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach
Użytkownik
7 minut temu, BloodyMen napisał:

Kupie enchant na 30 lvl dziala, lecz powiedz mi czy da sie zablokowac "zapraszam na server ip.pl" a "polecam fajny sever" nie? Wez przemysl cos zanim to napiszesz kolego

if message contains "server" or "serwer" and ".pl" or ".net" i tak dalej.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach
Zasłużony

@BloodyV8 tak da się tak zablokować, wystarczy zapętlić wiadomość i ją przeanalizować, czy jest spacja po końcówce, czy jest przed itp.

`Osoba ktore pisza "kolejna antty reklama" .. "pisane w 1 sek" to idioci...`

Osoba ktore pisze ze napisane na szybko to idioci...

Skoro napisane na szybko to nie wrzucaj już lepiej użyć mojego CenzorPlus i tak spotkasz się z hejtem od wszystkich, pewnie nikomu się to nie przyda, a ty będziesz musiał spamować napisane na szybko.

Jak dla mnie to słabe, mógłbym taki kod z pamięci wyrecytować, mimo, że dawno nie pisałem.

 

Dodaj blokowanie cyferkowych xxx.xxx.xxx.xxx gdzie x to cyfra

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach
Użytkownik
Dnia 7.12.2016 o 19:59, jahumen napisał:

@BloodyV8 tak da się tak zablokować, wystarczy zapętlić wiadomość i ją przeanalizować, czy jest spacja po końcówce, czy jest przed itp.

`Osoba ktore pisza "kolejna antty reklama" .. "pisane w 1 sek" to idioci...`

Osoba ktore pisze ze napisane na szybko to idioci...

Skoro napisane na szybko to nie wrzucaj już lepiej użyć mojego CenzorPlus i tak spotkasz się z hejtem od wszystkich, pewnie nikomu się to nie przyda, a ty będziesz musiał spamować napisane na szybko.

Jak dla mnie to słabe, mógłbym taki kod z pamięci wyrecytować, mimo, że dawno nie pisałem.

 

Dodaj blokowanie cyferkowych xxx.xxx.xxx.xxx gdzie x to cyfra

po 1 nie kojarze zadnego BloodyV8 a o ile pamietam to myszka. Po 2 nie reklamuj sie. Po 3 chociaz byś pomyślał, że wszystko jest ok, a serwer <spacja>pl nie bylo by blokowane po uzyciu "server" or "serwer" and ".pl" ..

 

Pozdrawiam.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach
Użytkownik

Będę szczery, takich skryptów jest mnóstwo a ten niczym się nie wyróżnia.

Jeśli chcesz zrobić dobry skrypt, to:

  • zrób taki, który jeszcze nie istnieje lub jest skryptów tego typu bardzo mało
  • maksymalnie ogranicz długość kodu
  • i co najważniejsze, dobry skrypt musi się wyróżniać oryginalnymi, przydatnymi funkcjami

Patrząc na takie skrypty mam wrażenie że chyba czas zacząć pisać pluginy...

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach
Użytkownik
37 minut temu, Reedzev_ napisał:

Będę szczery, takich skryptów jest mnóstwo a ten niczym się nie wyróżnia.

Jeśli chcesz zrobić dobry skrypt, to:

  • zrób taki, który jeszcze nie istnieje lub jest skryptów tego typu bardzo mało
  • maksymalnie ogranicz długość kodu
  • i co najważniejsze, dobry skrypt musi się wyróżniać oryginalnymi, przydatnymi funkcjami

Patrząc na takie skrypty mam wrażenie że chyba czas zacząć pisać pluginy...

Czesc, pluginami zajmuję się również już jakiś czas. Ostatnio nasz kochany eclipse wywala mi błędy przy odpalaniu, z informacji wynika, że błąd jest w JDK, lecz nwm dlaczego, skoro do niedawna hulało na tym JDK. Możliwe, że po updacie Javy coś się schrzaniło.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

Żeby dodać komentarz, musisz założyć konto lub zalogować się

Tylko zarejestrowani użytkownicy mogą dodawać komentarze

Dodaj konto

Załóż nowe konto. To bardzo proste!

Zarejestruj nowe konto

Zaloguj się

Posiadasz już konto? Zaloguj się tutaj.

Zaloguj się teraz


  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.

×